Bug 658052 - cannot install beaker on fedora 14
Summary: cannot install beaker on fedora 14
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Retired
Component: command line
Version: 0.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-29 08:50 UTC by Han Pingtian
Modified: 2011-05-19 19:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 19:49:25 UTC


Attachments (Terms of Use)

Description Han Pingtian 2010-11-29 08:50:23 UTC
Description of problem:
I am using the repo come from beaker's user guide:

For Fedora 14

wget -O /etc/yum.repos.d/beaker.repo http://beaker.engineering.redhat.com/harness/Fedora14/beaker.repo

But the installation failed:
[hpt@dhcp-65-144]~% sudo yum install beaker-client beaker-redhat
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package beaker-client.noarch 0:0.5.61-4.git.30.916b03e.fc14 set to be installed
--> Processing Dependency: beaker = 0.5.61-4.git.30.916b03e.fc14 for package: beaker-client-0.5.61-4.git.30.916b03e.fc14.noarch
--> Processing Dependency: kobo-client >= 0.3 for package: beaker-client-0.5.61-4.git.30.916b03e.fc14.noarch
--> Processing Dependency: python-lxml for package: beaker-client-0.5.61-4.git.30.916b03e.fc14.noarch
--> Processing Dependency: python-setuptools for package: beaker-client-0.5.61-4.git.30.916b03e.fc14.noarch
--> Processing Dependency: python-krbV for package: beaker-client-0.5.61-4.git.30.916b03e.fc14.noarch
---> Package beaker-redhat.noarch 0:0.1.20-1.fc14 set to be installed
--> Processing Dependency: pykickstart for package: beaker-redhat-0.1.20-1.fc14.noarch
--> Processing Dependency: beakerlib-redhat for package: beaker-redhat-0.1.20-1.fc14.noarch
--> Processing Dependency: snake for package: beaker-redhat-0.1.20-1.fc14.noarch
--> Running transaction check
---> Package beaker.noarch 0:0.5.61-4.git.30.916b03e.fc14 set to be installed
---> Package beaker-redhat.noarch 0:0.1.20-1.fc14 set to be installed
--> Processing Dependency: beakerlib-redhat for package: beaker-redhat-0.1.20-1.fc14.noarch
---> Package kobo-client.noarch 0:0.3.2-1.fc14 set to be installed
--> Processing Dependency: kobo = 0.3.2-1.fc14 for package: kobo-client-0.3.2-1.fc14.noarch
---> Package pykickstart.noarch 0:1.77-2.fc14 set to be installed
---> Package python-krbV.x86_64 0:1.0.90-2.fc14 set to be installed
---> Package python-lxml.x86_64 0:2.2.8-1.fc14 set to be installed
---> Package python-setuptools.noarch 0:0.6.14-3.fc14 set to be installed
---> Package snake.noarch 0:0.11-1.0.20.fc14 set to be installed
--> Processing Dependency: pax for package: snake-0.11-1.0.20.fc14.noarch
--> Running transaction check
---> Package beaker-redhat.noarch 0:0.1.20-1.fc14 set to be installed
--> Processing Dependency: beakerlib-redhat for package: beaker-redhat-0.1.20-1.fc14.noarch
---> Package kobo.noarch 0:0.3.2-1.fc14 set to be installed
---> Package pax.x86_64 0:3.4-10.fc12 set to be installed
--> Finished Dependency Resolution
Error: Package: beaker-redhat-0.1.20-1.fc14.noarch (beaker)
           Requires: beakerlib-redhat
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It seems that there is no beaker-redhat in http://beaker.engineering.redhat.com/harness/fedora-14/x86_64/.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.