Bug 658145 - AVC denial for write to pipe in prep/post script in rpm
Summary: AVC denial for write to pipe in prep/post script in rpm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted
Version: 5.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 640580
TreeView+ depends on / blocked
 
Reported: 2010-11-29 14:12 UTC by Miroslav Vadkerti
Modified: 2014-10-24 08:25 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-2.4.6-296.el5
Doc Type: Bug Fix
Doc Text:
Due to an error in an SELinux policy, pre-installation and post-installation scripts in RPM packages were unable to write to a pipe. This has been fixed, and SELinux no longer prevents these scripts from performing their work.
Clone Of:
Environment:
Last Closed: 2011-01-13 21:51:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0026 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2011-01-12 16:11:15 UTC

Description Miroslav Vadkerti 2010-11-29 14:12:03 UTC
Description of problem:
type=AVC msg=audit(1291036477.207:4741): avc:  denied  { write } for  pid=8427 comm="snmpd" path="pipe:[1509421]" dev=pipefs ino=1509421 scontext=root:system_r:snmpd_t:s0 
                 tcontext=root:system_r:rpm_script_t:s0-s0:c0.c1023 tclass=fifo_file

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-294.el5

How reproducible:
100%

Steps to Reproduce:
1. Run /CoreOS/rpm/Regression/bz471591_brokenpipe
  
Actual results:
AVC

Expected results:
no AVC

Additional info:

Comment 2 Daniel Walsh 2010-11-29 16:05:23 UTC
Miroslav just backport the leaks code from RHEL6 and add

rpm_dontaudit_leaks(domain)

Comment 3 Miroslav Grepl 2010-11-29 16:09:57 UTC
Strange, should be already there ... I am going to check it.

Comment 4 Miroslav Grepl 2010-11-30 09:35:07 UTC
I have found a bug.

Fixed in selinux-policy-2.4.6-296.el5.

Comment 9 Jaromir Hradilek 2011-01-05 16:29:49 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to an error in an SELinux policy, pre-installation and post-installation scripts in RPM packages were unable to write to a pipe. This has been fixed, and SELinux no longer prevents these scripts from performing their work.

Comment 11 errata-xmlrpc 2011-01-13 21:51:43 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0026.html


Note You need to log in before you can comment on or make changes to this bug.