Bug 65815 - konsole not displaying line draw characters for mc, ntsysv, iptraf and so on
konsole not displaying line draw characters for mc, ntsysv, iptraf and so on
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 18:23 EDT by Kevin Adams
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Adams 2002-05-31 18:23:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
After upgrading from 7.2 to 7.3, konsole no longer displays the correct line 
drawing characters, like boxes and borders, for fullscreen apps such as mc, 
iptraf, and ntsysv. I've got the same result on 2 different machines. It worked 
before the upgrade but not immediately after, and with no other changes. No 
settings within konsole seem to fix.

Version-Release number of selected component (if applicable):
# konsole -v
Qt: 3.0.3
KDE: 3.0.0-10
Konsole: 1.1


How reproducible:
Always

Steps to Reproduce:
1. Run konsole by clicking the shell button on kde default panel
2. Enter mc, iptraf or ntsysv

Actual Results:  What are normally line drawing or box characters are now 
jibberish. Other text characters appear normal.

Expected Results:  I wanted to see the normal lines used to make borders and 
boxes the way it worked before I upgraded to 7.3. This worked fine in 7.2.

Additional info:

Running mc -a works, but that option disables the use of graphic characters for 
line drawing. Iptraf and ntsysv as well as other apps do not have that option. 
I also use konsole to connect to AIX, which needs the line drawing as well. It 
use to work too.

I've run the following command on a rh7.2 system that works right, and a rh7.3 
system that was upgraded and the output is the same on both:

# chkfontpath --list
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/cyrillic
8: /usr/X11R6/lib/X11/fonts/CID
9: /usr/X11R6/lib/X11/fonts/local
10: /usr/X11R6/lib/X11/fonts/latin2/Type1
11: /usr/share/fonts/default/TrueType
12: /usr/share/fonts/default/Type1
13: /usr/share/AbiSuite/fonts
14: /usr/share/fonts/ja/TrueType
Comment 1 Kevin Adams 2002-06-01 19:29:16 EDT
It turns out this only happens when accessing via MS Windows using Exceed 
7.1.0.0 and not at the KDE physical console via startx.

So, what changed from 7.2 to 7.3 that would cause this?

I can connect via Exceed to a 7.2 box just fine.

Thanks
Comment 2 Petr Rockai 2006-07-17 14:23:53 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 3 Bill Nottingham 2006-10-18 14:24:19 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.