Bug 658247 - switch desk does not
switch desk does not
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
14
Unspecified Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-29 14:38 EST by Todd
Modified: 2012-08-16 17:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 17:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Todd 2010-11-29 14:38:46 EST
Hi All,

$ rpm -qa \*switchdesk\*
switchdesk-4.0.9-8.fc14.1.noarch
switchdesk-gui-4.0.9-8.fc14.1.noarch

After doing a group install on Xfce, I tried to get switchdesk to switch me to Xfce but it did not.  Work around: use the "session" at the bottom of the greater screen, which does work.

Be nice if switchdesk worked too.

Many thanks,
-T
Comment 1 Stephen John Smoogen 2010-12-10 12:57:23 EST
Ok the problem is that .Xclients is no longer looked at in the startup. As far as I can tell the only way it gets used is if Gnome or KDE are not installed on the system. Otherwise the system looks at the .dmrc file to figure out what desktop to use. Should be a simple patch to change functionality to add that file per usage.
Comment 2 Rex Dieter 2010-12-11 21:26:53 EST
Looks like switchdesk needs a dep on xorg-x11-xinit-session (which provides support for ~/.xsession and ~/.Xclients)
Comment 3 Stephen John Smoogen 2010-12-12 14:18:44 EST
Ah.. ok. I wonder if a .dmrc addition would be useful also. I noticed it has not been updated to deal with LXDE and such.
Comment 4 Christoph Wickert 2010-12-13 19:01:25 EST
(In reply to comment #2)
> Looks like switchdesk needs a dep on xorg-x11-xinit-session (which provides
> support for ~/.xsession and ~/.Xclients)

Reading bug 142260 I was under the impression that ~/.Xclients is considered obsolete and /etc/X11/xinit/Xsession.d is the way to go.

(In reply to comment #3)
> Ah.. ok. I wonder if a .dmrc addition would be useful also. I noticed it has
> not been updated to deal with LXDE and such.

See bug 478529 which was closed WONTFIX.
Comment 5 Jack Perdue 2011-08-18 14:02:22 EDT
Installing xorg-x11-xinit-session doesn't help.  If gdm is the DM _and_ the aforementioned package is installed, then it still ignores the ~/.Xclients-default that switchdesk wrote. 

gdm-2.32.1-2.fc14.x86_64
switchdesk-4.0.9-8.fc14.1.noarch
xorg-x11-xinit-session-1.0.9-18.fc14.x86_64

Very annoying/frustrating.  Fortunately Todd's workaround hint made me stare at the gdm greeter long enough to figure out I could select my WM _after_ selecting my login (I thought it was there somewhere but it doesn't show up until a login is chosen... and it isn't completely obvious).

If ~/.Xclients-default is being obsoleted/deprecated _AND_ being ignored by Fedora's default DM (gdm), then switchdesk really should be updated to use a file that will actually have an effect, be that .dmrc or a file in /etc/X11/xinit/Xsession.d 

And it wouldn't hurt if the gdm greeter made the choice of WM more obvious (but that's a bug for a different package)...
Comment 6 Jack Perdue 2011-08-18 14:08:00 EDT
p.s. if nothing else, switchdesk could add a note to ~/.Xclients-default that includes a blurb along the lines of "If gdm/kdm is your display manager, then you may need to manually edit ~/.dmrc"... that would least give a hint to the (non-novice) user trying to figure why it isn't working.
Comment 7 Fedora End Of Life 2012-08-16 17:08:36 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.