Bug 658250 - "500 Error - Internal Server Error" upon clicking "Use in SSM" button from System Groups page.
Summary: "500 Error - Internal Server Error" upon clicking "Use in SSM" button from Sy...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 1.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Lukas Zapletal
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space13
TreeView+ depends on / blocked
 
Reported: 2010-11-29 19:45 UTC by Ron Helzer
Modified: 2011-02-08 08:42 UTC (History)
1 user (show)

Fixed In Version: spacewalk-web-1.3.10-1
Doc Type: Bug Fix
Doc Text:
Clone Of: 658256
: 660606 (view as bug list)
Environment:
Last Closed: 2011-02-08 08:42:05 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 658256 0 low CLOSED "500 Error - Internal Server Error" when scheduling remote commands. 2021-02-22 00:41:40 UTC

Internal Links: 658256

Description Ron Helzer 2010-11-29 19:45:50 UTC
Description of problem:

The following exception occurred while executing this request:
 GET /network/systems/ssm/system_list.pxt HTTP/1.1 (from browser)
 /network/systems/ssm/system_list.pxt (from Apache)

Date:
  Mon Nov 29 14:39:47 2010

Headers:
  Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Accept-Encoding: gzip,deflate
  Accept-Language: en-us,en;q=0.5
  Connection: keep-alive
  Cookie: pxt-session-cookie=4438xa5df2cfe34c510c76bb1929ad23ad0c6
  Host: spacewalk.hgvc.com
  Keep-Alive: 115
  Referer: https://spacewalk.hgvc.com/rhn/systems/SystemGroupList.do
  User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 (CK-IBM) Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)

Form variables:


User Information:
  User rhelzer (id 1, org_id 1)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  RHN::Exception: DBD::Oracle::db prepare_cached failed: ORA-00904: "OV"."SERVER_ID": invalid identifier (DBD ERROR: error possibly near <*> indicator at char 704 in '
  SELECT  SERVER_ID AS ID, SECURITY_ERRATA, BUG_ERRATA, ENHANCEMENT_ERRATA, OUTDATED_PACKAGES, SERVER_NAME,
          SERVER_ADMINS, GROUP_COUNT, NOTE_COUNT, MODIFIED, CHANNEL_LABELS, CHANNEL_ID, HISTORY_COUNT,
          LAST_CHECKIN_DAYS_AGO, PENDING_UPDATES, OS, RELEASE, SERVER_ARCH_NAME, LAST_CHECKIN, LOCKED,
       ( SELECT  CASE
                   MAX(CASE PS.state WHEN 'OK' THEN 1 WHEN 'PENDING' THEN 2 WHEN 'UNKNOWN' THEN 3 WHEN 'WARNING' THEN 4 WHEN 'CRITICAL' THEN 5 END)
                         WHEN 1 THEN 'OK' WHEN 2 THEN 'PENDING' WHEN 3 THEN 'UNKNOWN' WHEN 4 THEN 'WARNING' WHEN 5 THEN 'CRITICAL' END ST
         FROM  rhn_probe_state PS
         LEFT OUTER JOIN rhn_check_probe CP ON <*>OV.server_id = CP.host_id
          WHERE  PS.probe_id = CP.probe_id
         GROUP BY OV.server_id ) MONITORING_STATUS,
       COALESCE((SELECT 1 FROM rhnServerFeaturesView SFV WHERE SFV.server_id = OV.server_id AND SFV.label = 'ftr_system_grouping'), 0) AS SELECTABLE
    FROM  rhnServerOverview OV
   WHERE  server_id IN (:p2, :p5, :p3, :p1, :p0, :p4, :p6)
ORDER BY  UPPER(NVL(SERVER_NAME, '(none)')), SERVER_ID
') [for Statement "
  SELECT  SERVER_ID AS ID, SECURITY_ERRATA, BUG_ERRATA, ENHANCEMENT_ERRATA, OUTDATED_PACKAGES, SERVER_NAME,
          SERVER_ADMINS, GROUP_COUNT, NOTE_COUNT, MODIFIED, CHANNEL_LABELS, CHANNEL_ID, HISTORY_COUNT,
          LAST_CHECKIN_DAYS_AGO, PENDING_UPDATES, OS, RELEASE, SERVER_ARCH_NAME, LAST_CHECKIN, LOCKED,
       ( SELECT  CASE
                   MAX(CASE PS.state WHEN 'OK' THEN 1 WHEN 'PENDING' THEN 2 WHEN 'UNKNOWN' THEN 3 WHEN 'WARNING' THEN 4 WHEN 'CRITICAL' THEN 5 END)
                         WHEN 1 THEN 'OK' WHEN 2 THEN 'PENDING' WHEN 3 THEN 'UNKNOWN' WHEN 4 THEN 'WARNING' WHEN 5 THEN 'CRITICAL' END ST
         FROM  rhn_probe_state PS
         LEFT OUTER JOIN rhn_check_probe CP ON OV.server_id = CP.host_id
          WHERE  PS.probe_id = CP.probe_id
         GROUP BY OV.server_id ) MONITORING_STATUS,
       COALESCE((SELECT 1 FROM rhnServerFeaturesView SFV WHERE SFV.server_id = OV.server_id AND SFV.label = 'ftr_system_grouping'), 0) AS SELECTABLE
    FROM  rhnServerOverview OV
   WHERE  server_id IN (:p2, :p5, :p3, :p1, :p0, :p4, :p6)
ORDER BY  UPPER(NVL(SERVER_NAME, '(none)')), SERVER_ID
"]
  RHN::DB /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB.pm 228 RHN::Exception::DB::throw
  RHN::DB::DataSource /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/DataSource.pm 73 RHN::DB::handle_error
  RHN::DB::DataSource /usr/lib/perl5/vendor_perl/5.8.8/RHN/DB/DataSource.pm 52 RHN::DB::DataSource::run_query
  RHN::DataSource /usr/lib/perl5/vendor_perl/5.8.8/RHN/DataSource.pm 144 RHN::DB::DataSource::run_complex_query
  Sniglets::ListView::List /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/ListView/List.pm 1220 RHN::DataSource::elaborate
  Sniglets::ListView::SystemList /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/ListView/SystemList.pm 901 Sniglets::ListView::List::default_provider
  Sniglets::ListView::List /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/ListView/List.pm 908 Sniglets::ListView::SystemList::in_set_provider
  Sniglets::Lists /usr/lib/perl5/vendor_perl/5.8.8/Sniglets/Lists.pm 119 Sniglets::ListView::List::render
  PXT::Parser /usr/lib/perl5/vendor_perl/5.8.8/PXT/Parser.pm 160 Sniglets::Lists::listview
  PXT::Parser /usr/lib/perl5/vendor_perl/5.8.8/PXT/Parser.pm 72 PXT::Parser::expand_tag
  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 522 PXT::Parser::expand_tags
  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 117 PXT::ApacheHandler::pxt_parse_data
  PXT::ApacheHandler /usr/lib/perl5/vendor_perl/5.8.8/PXT/ApacheHandler.pm 117 (eval)
  main -e 0 PXT::ApacheHandler::handler
  main -e 0 (eval)


Version-Release number of selected component (if applicable):

1.2


How reproducible:

Every time


Steps to Reproduce:
1. Go to "System Groups" page https://spacewalk.hgvc.com/rhn/systems/SystemGroupList.do
2. Click "Use in SSM" button next to any group.
3. Receive "500 Error - Internal Server Error"
  
Actual results:

Systems are selected despite 500 error.

Expected results:

No "500 Error - Internal Server Error"


Additional info:

Comment 2 Lukas Zapletal 2010-12-06 07:56:57 UTC
Dupe. Fixed in master. Thanks for the report Ron!

Comment 3 Lukas Zapletal 2010-12-08 07:01:51 UTC
Commit: 3589dbc33ea667fc7e5d17ec5ee8e91eaeb0c8d4

Comment 4 Tomas Lestach 2011-02-03 12:21:40 UTC
Moving ON_QA ...

Comment 5 Tomas Lestach 2011-02-08 08:42:05 UTC
This bug has been fixed in Spacewalk 1.3.


Note You need to log in before you can comment on or make changes to this bug.