This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 65828 - sulogin - misleading message
sulogin - misleading message
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: SysVinit (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-01 15:29 EDT by Vlado Potisk
Modified: 2014-03-16 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-19 05:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2002-06-01 15:29:41 EDT
Description of Problem:

When something goes wrong during startup, sulogin is called
and it displays:
  ... or type Ctrl-D for normal startup
but when I hit Ctrl-D I get a reboot.

I understand that reboot is the correct behavior, but would
it be possible to alter the message in some future release ?
It should definitely not be promising a "normal startup".
Comment 1 Bill Nottingham 2002-07-18 21:27:39 EDT
The problem is that while the message comes from sulogin, the fact that it
reboots is because of the code that *calls* sulogin; sulogin itself doesn't know
that it will reboot afterwards. So you'd be changing the message for cases where
it would be relevant.
Comment 2 Vlado Potisk 2002-07-19 05:43:54 EDT
As you wrote, sulogin does not know what is coming next.
It seems logical to me that in such situation it should not
promise a normal startup. I would suggest a neutral message
like:
    Give root password for maintenance
    (or type Control-D to continue):
Anyway it is not a real bug, just a small annoyance, so simply
close this bug if you prefer.
Comment 3 Bill Nottingham 2002-12-02 14:37:14 EST
Changed in 2.84-6.

Note You need to log in before you can comment on or make changes to this bug.