Bug 65829 - netdump RPM missing core module (netconsole)
netdump RPM missing core module (netconsole)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: netdump (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-01 18:44 EDT by Stephen Samuel
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 14:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Samuel 2002-06-01 18:44:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
atempting to start netdump server fails because the netconsole module
is missing.
   The netdump init.d script is simply a wraper for starting netsonsole

service netdump start
netdump@netdump-server's password:
initializing netdump modprobe: Can't locate module netconsole
                                                           [FAILED]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install redhat 7.3 , including netdump and netdump-server on a virgin box
2.configure netdump (sysconfig/netdump) to dump to localhost (or any other box
with netdump-server installled)
3.service start sysconfig
	

Actual Results:  
% service netdump start
netdump@netdump-server's password:
initializing netdump modprobe: Can't locate module netconsole
                                                           [FAILED]


Expected Results:   [  OK  ]

Additional info:
Comment 1 Stephen Samuel 2002-06-04 14:55:13 EDT
oops!
It's the netdump client which refuses to startup, not the server.
   the netdump server starts up just fine (as can be implicitly 
   determined from my session capture)
Comment 2 Michael K. Johnson 2002-07-12 08:23:42 EDT
The netconsole module is provided by the kernel, for kernels for which the
netdump facility is provided; Red Hat Linux 7.3's kernel does not provide
this facility.  We included the netdump packages so that Red Hat Linux 7.3
could act as a netdump-server and it's one source package; also, if we ever
add netconsole/netdump support to an errata kernel the necessary user-space
package is already there.

Note You need to log in before you can comment on or make changes to this bug.