This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 65831 - NCHardwareList:288:save KeyError: options
NCHardwareList:288:save KeyError: options
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-06-01 21:01 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 12:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-01 21:01:17 EDT
Description of Problem: 
 
This is a new install of RH 7.3 with KDE & Gnome, using the control panel 
to configure the network because only one of my 2 NICs was recognized. 
At some point the configure tool crashed and gave me a printout asking 
me to submit this report. 
 
Version-Release number of selected component (if applicable): 
 
I don't know. 
 
How Reproducible: 
 
I didn't try very hard, and I couldn't remember what I'd done, because 
I was having trouble understanding what the system was doing.  I'm new to 
these tools.  Part of it was I had clicked many times, not realizing how 
slow it is to come up with the dialogs.  But then there are two tools 
in the control panel that -might- have been the one I needed.  And then 
again I wasn't quite sure how to do this. 
 
I was trying to change the one it had recognized already to be eth1, and 
have the unrecognized one be eth0.  That's because this is the way I had 
it in RH 7.1. 
 
 
Steps to Reproduce: 
1.  
2.  
3.  
 
Actual Results: 
 
Bug report, one in a dialog, one that I could save.  They both follow: 
Please visit http://bugzilla.redhat.com/bugzilla/ ! 
File a bug against component redhat-config-network. Thank you! 
 
Traceback (innermost last): 
  File "/usr/sbin/neat", line 1402, in ? 
    gtk.mainloop() 
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop 
    _gtk.gtk_main() 
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__ 
    ret = apply(self.func, a) 
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked 
    self.save() 
  File "/usr/sbin/neat", line 287, in save 
    self.saveHardware() 
  File "/usr/sbin/neat", line 302, in saveHardware 
    hardwarelist.save() 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", line 
288, in save 
    modules[hw.Card.ModuleName]['options'][confkey] = 
str(hw.Card.__dict__[selfkey]) 
KeyError: options 
 
******************************************************************************** 
Traceback (innermost last): 
  File "/usr/sbin/neat", line 1402, in ? 
    gtk.mainloop() 
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop 
    _gtk.gtk_main() 
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__ 
    ret = apply(self.func, a) 
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked 
    self.save() 
  File "/usr/sbin/neat", line 287, in save 
    self.saveHardware() 
  File "/usr/sbin/neat", line 302, in saveHardware 
    hardwarelist.save() 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", line 
288, in save 
    modules[hw.Card.ModuleName]['options'][confkey] = 
str(hw.Card.__dict__[selfkey]) 
KeyError: options 
 
Local variables in innermost frame: 
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 8361250> 
hw: <netconfpkg.HardwareList.Hardware instance at 8686b08> 
selfkey: IoPort 
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 86831f0> 
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 845e598> 
confkey: io 
self: [<netconfpkg.HardwareList.Hardware instance at 8477a68>, 
<netconfpkg.HardwareList.Hardware instance at 8686b08>] 
[kevin@glynnis kevin]$ 
 
Expected Results: 
 
 
Additional Information:
Comment 1 Harald Hoyer 2002-06-26 12:13:41 EDT
already fixed in CVS
Comment 2 Harald Hoyer 2002-10-23 05:51:59 EDT
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Note You need to log in before you can comment on or make changes to this bug.