Bug 658363 - Several fonts interfere with citrix receiver
Several fonts interfere with citrix receiver
Status: CLOSED DUPLICATE of bug 634039
Product: Fedora
Classification: Fedora
Component: cjkuni-uming-fonts (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 01:25 EST by masterson.andrew
Modified: 2011-01-31 04:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-31 04:14:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description masterson.andrew 2010-11-30 01:25:11 EST
Description of problem:

When trying to connect remotely to a citrix XenApp server, you have to uninstall 3 fonts in order to get it to work.

You can log into the gateway, but when trying to launch an application you receive the following errors in /var/log/Xorg.0.log

[ 10428.297] FreeType: couldn't find encoding 'iso8859-13' for '/usr/share/fonts/sazanami/mincho/sazanami-mincho.ttf'

After "yum erase sazanami*", then you get:

[ 10946.866] FreeType: couldn't find encoding 'gb2312.1980-0' for '/usr/share/fonts/cjkuni-uming/uming.ttc'

After "yum erase cjkuni-uming", then you get:

[ 10984.067] FreeType: couldn't find encoding 'gb2312.1980-0' for '/usr/share/fonts/cjkuni-ukai/ukai.ttc'

After "yum erase cjkuni-ukai" you can finally connect to applications.

This uninstalls java off the machine because of dependencies, which is a huge, huge, huge pain in the buttox.


Version-Release number of selected component (if applicable):

ICAClient-11.100-1.i386.rpm (from http://www.citrix.com/English/ss/downloads/details.asp?downloadId=3323&productId=186&c1=sot2755 )

 sazanami-fonts-common                          noarch                      0.20040629-14.fc13                           @updates                       38 k

 sazanami-gothic-fonts                          noarch                      0.20040629-14.fc13                           @updates                      7.3 M

 sazanami-mincho-fonts                          noarch                      0.20040629-14.fc13                           @updates                       10 M

 cjkuni-uming-fonts                        noarch                        0.2.20080216.1-42.fc13                        @updates                         21 M

 cjkuni-ukai-fonts                        noarch                        0.2.20080216.1-42.fc13                         @updates                         17 M

 java-1.6.0-openjdk                             x86_64                      1:1.6.0.0-45.1.8.3.fc13                      @updates                       80 M

 java-1.6.0-openjdk-plugin                      x86_64                      1:1.6.0.0-45.1.8.3.fc13                      @updates                      190 k



How reproducible:

Install latest java and fonts onto box.  Download citrix receiver, install, and try to connect to a XenApp application.

Steps to Reproduce:
1. Install latest java onto box (installs fonts listed above for deps)
2. Download and install citrix client (sudo yum --nogpgcheck localinstall ICAClient-11.100-1.i386.rpm)
3. Attempt to connect to a XenApp application
  
Actual results:

XenApp application does not start, and posts errors in /var/log/Xorg.0.log

Expected results:

XenApp launches application

Additional info:

Can be remedied by uninstalling 3 fonts and removing java from box - not an optimal solution.  This bug has been present since FC11, but there was never a java dep to worry about before.  Now that there is a java dep it is debilitating.
Comment 1 Peng Wu 2010-11-30 03:22:32 EST
We encountered the problem before, please see:
https://bugzilla.redhat.com/show_bug.cgi?id=634039
Bug 634039 - encodings in /usr/share/X11/fonts/encodings/large are not read by X server

Maybe you can also open a bug against  java-1.6.0-openjdk to see whether they can remove the fonts dependencies.
Comment 2 Peng Wu 2010-11-30 05:25:59 EST
Hi Masterson Andrew,
  Does the above bug fixes your problem?
Comment 3 masterson.andrew 2010-12-01 22:55:07 EST
I installed 

 java-1.6.0-openjdk    x86_64    1:1.6.0.0-46.1.8.3.fc13       updates     25 M
 java-1.6.0-openjdk-plugin   x86_64   1:1.6.0.0-46.1.8.3.fc13   updates   102 k

which don't seem to have any font dependencies, and the citrix client worked fine (no font errors).

Then, to test, I did

# cd /usr/share/X11/fonts/encodings
# mkfontdir -n -e /usr/share/X11/fonts/encodings -e /usr/share/X11/fonts/encodings/large

from the bug report listed above, and installed

 cjkuni-uming-fonts     noarch     0.2.20080216.1-42.fc13     updates     8.9 M

and the citrix client still works.  So it appears that the mkfontdir command fixes whatever was causing the X applications to break.

From reading the bug report it looks like this is fixed in Rawhide.
Comment 4 Peng Wu 2010-12-02 21:12:42 EST
requested Fedora 13/14 updates.
On Bug 634039 - encodings in /usr/share/X11/fonts/encodings/large are not read by X server
Comment 5 Rene Jr Purcell 2010-12-14 13:23:56 EST
I'm under Fedora 13 lastest update on Dec. 14 and I had the same problem explained in this ticket. The citrix Ica client was working fine since the release of F13, and update seems to have caused this.

I've use the suggestion in comment #3:
# cd /usr/share/X11/fonts/encodings
# mkfontdir -n -e /usr/share/X11/fonts/encodings -e /usr/share/X11/fonts/encodings/large

And doing this fixed my problem!
Comment 6 Akira TAGOH 2011-01-31 04:14:00 EST
According to the above comments, this isn't an issue in this package. the root cause should be fixed with Bug#634039. closing.

*** This bug has been marked as a duplicate of bug 634039 ***

Note You need to log in before you can comment on or make changes to this bug.