Bug 658368 - [abrt] man-db-2.5.7-6.fc14: __libc_message: Process /usr/bin/man was killed by signal 6 (SIGABRT)
[abrt] man-db-2.5.7-6.fc14: __libc_message: Process /usr/bin/man was killed b...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
14
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
abrt_hash:fad0bf8f486225daaef38c928a5...
:
Depends On:
Blocks: 668576
  Show dependency treegraph
 
Reported: 2010-11-30 02:06 EST by Enrique
Modified: 2011-01-21 06:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-21 06:54:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (2.63 KB, text/plain)
2010-11-30 02:06 EST, Enrique
no flags Details

  None (edit)
Description Enrique 2010-11-30 02:06:53 EST
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: man /usr/bin/phoronix-test-suite
comment: It is always reproducible.
component: man-db
crash_function: __libc_message
executable: /usr/bin/man
kernel: 2.6.35.6-48.fc14.i686.PAE
package: man-db-2.5.7-6.fc14
rating: 4
reason: Process /usr/bin/man was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1291100672
uid: 4876

How to reproduce
-----
1. I simply executed man /usr/bin/phoronix-test-suite, altough it happens with any "man"  which includes the full comman path, like "man /bin/ls"
Comment 1 Enrique 2010-11-30 02:06:55 EST
Created attachment 463655 [details]
File: backtrace
Comment 2 Colin Watson 2010-12-02 08:10:37 EST
It's hard to tell for certain since this is a memory corruption bug, but this sounds very like a bug I fixed in man-db 2.5.8:

Mon Nov 15 21:38:04 GMT 2010  Colin Watson  <cjwatson@debian.org>

        * src/man.c (local_man_loop): Simplify and improve code to make a
          temporary copy of manpathlist, in order that it can't free
          unallocated memory (may fix Savannah bug #31633).

See: https://savannah.nongnu.org/bugs/?31633

If you don't want to upgrade to 2.5.8 or newer, you should be able to apply http://bazaar.launchpad.net/~cjwatson/man-db/trunk/revision/1276 to 2.5.7 to fix this bug.
Comment 3 Ivana Varekova 2011-01-04 09:42:14 EST
Thanks Colin for your investigation.
man-db-2.5.7-7.fc14, which contains a patch Colin mention in previous coment, was just submitted to updates. Please fix this package the problem?
Comment 4 Enrique 2011-01-21 06:27:40 EST
 I have installed the last man-db-2.5.7-7.fc14 and the bug is indeed fixed. It can be closed.
 Thank you for your job!

Note You need to log in before you can comment on or make changes to this bug.