Bug 65842 - System will not boot if grub is placed on a scsi disk when ide disk is present
System will not boot if grub is placed on a scsi disk when ide disk is present
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-02 05:37 EDT by robert.nilsson
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 18:45:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description robert.nilsson 2002-06-02 05:37:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.1)

Description of problem:
When asked about grub/lilo during installation, I installed Grub on /dev/sda1. 
But with this choice my system will not boot. I had unplug my IDE drives and 
then start the installation all over again. I've had this problem (and 
reported it) with an earlier version of RedHat Linux, so I thought that this 
wouldn't be any problem now.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Both SCSI and IDE on system
2. Choose grub to be installed on first SCSI disk
3. Reboot .... -> Won't work!
	

Actual Results:  I'm not sure, but it seems that grub doesn't recide on the 
scsi disk at all. Maybe it installed grub on /dev/hda1 ???

Expected Results:  normal boot

Additional info:

As I said, this is a prior bug (I don't remeber any bug id).
It's not a high priority bug, I know that - but it's pretty frustrating that 
you have to physically unplug all your ide disks when planning on installing 
you Red Hat Linux. I've got 3 IDE disks and four scsi disks. My / resides 
on /dev/sda1 but everything else contains data for example /var /users etc.
Comment 1 Michael Fulbright 2002-06-04 10:43:53 EDT
Does your BIOS allow you to specify if the SCSI or IDE drive chain is booted
first?  Almost all PC BIOS's boot from the first IDE drive, and it takes custom
editting of the bootloader configuration to get it to boot from SCSI if IDE is
present.
Comment 2 robert.nilsson 2002-06-05 03:19:53 EDT
Yes it does and my IDE disks aren't even there.
It started as a 100% scsi system but since IDE disks are much much cheaper
I've installed a few large ones. My bootup sequence is:

1. Floppy
2. SCSI CD
3. SCSI Disk
4. none


But this is not the problem. After I've unplugged my IDE disks and installed 
the system, I can reconnect the IDE disks and everything works just fine.


/ Robert
Comment 3 Michael Fulbright 2002-06-12 12:57:51 EDT
I think we're planning on some future enhancements that would help in your
situation.
Comment 4 Jeremy Katz 2002-06-12 13:01:11 EDT
Dupe of a few others...  future releases allow changing what we detect your
drive order as.
Comment 5 Mike McLean 2003-01-10 18:45:06 EST
closing

Note You need to log in before you can comment on or make changes to this bug.