Bug 658422 - spacewalk-repo-sync doesn't trigger errata cache update
spacewalk-repo-sync doesn't trigger errata cache update
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Šimon Lukašík
:
: 654398 (view as bug list)
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-11-30 05:35 EST by Tomas Lestach
Modified: 2011-02-09 12:11 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.13-21
Doc Type: Bug Fix
Doc Text:
Cause: Running spacewalk-repo-sync did not automatically trigger errata cache rebuild. Consequence: applicable package updates were not visible. Fix: Running spacewalk-repo-sync now automatically triggers errata cache rebuild. Result: The results are astonishing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 11:16:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2010-11-30 05:35:21 EST
Description of problem:
When syncing repo to a channel, errata cache doesn't get updated for the affected channel.

Version-Release number of selected component (if applicable):
sat540

How reproducible:
always

Steps to Reproduce:
1. create a custom channel and subscribe a server to that channel
2. associate a repository to the channel and sync it (the repo shall contain at least one package update for the server)
3. wait until channel repodata is generated and at least 10 minutes to let the errata cache to get regenerated
4. check WebUI to see package updates

Actual results:
No package updates

Expected results:
All possible package updates displayed

Additional info:
spacewalk-repo-sync shall trigger a ErrataCacheTask into the taskomatic queue when it has modified channel content (by inserting update_errata_cache_by_channel into the rhnTaskQueue).
Comment 1 Milan Zazrivec 2010-12-13 10:20:54 EST
Taking.
Comment 2 Milan Zazrivec 2010-12-16 10:11:08 EST
spacewalk.git master: 37efecb997ef90a71269fc6594f02ff9eb6c1f6e
Comment 3 Miroslav Suchý 2010-12-16 12:43:12 EST
cherry-picked to satellite.git as commit ef45b621d4989c7f2246e023dfacffe4165035a4
Comment 4 Šimon Lukašík 2011-01-10 08:18:11 EST
Moving to Verified:

Testing procedure:
- After the reposync updates are shown on webui
- Client is able to fetch packages right after, repodata regeneration
- When multiple channels assigned to a repository, errata cache is 
  regenerated only for appropriate channel

Verified against:
spacewalk-backend-1.2.13-23.el5sat
Comment 5 Florian Nadge 2011-01-27 06:28:09 EST
Please be so kind and add a few key words to the Technical Note field of this
bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks
Comment 6 Florian Nadge 2011-01-27 06:28:10 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:
Comment 7 Milan Zazrivec 2011-01-27 07:17:35 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,7 @@
-Cause:
+Cause: Running spacewalk-repo-sync did not automatically trigger yum repodata rebuild.
 
-Consequence:
+Consequence: yum repodata was not rebuilt after running spacewalk-repo-sync.
 
-Fix:
+Fix: Running spacewalk-repo-sync now automatically triggers repodata rebuild.
 
-Result:+Result: The results are astonishing.
Comment 8 Milan Zazrivec 2011-01-28 08:06:44 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,7 @@
-Cause: Running spacewalk-repo-sync did not automatically trigger yum repodata rebuild.
+Cause: Running spacewalk-repo-sync did not automatically trigger errata cache rebuild.
 
-Consequence: yum repodata was not rebuilt after running spacewalk-repo-sync.
+Consequence: applicable package updates were not visible.
 
-Fix: Running spacewalk-repo-sync now automatically triggers repodata rebuild.
+Fix: Running spacewalk-repo-sync now automatically triggers errata cache rebuild.
 
 Result: The results are astonishing.
Comment 9 Florian Nadge 2011-02-01 09:09:22 EST
Milan, many thanks for the excellent CCFR.
Comment 10 errata-xmlrpc 2011-02-01 11:16:31 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0190.html
Comment 11 Clifford Perry 2011-02-09 12:11:42 EST
*** Bug 654398 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.