Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 65845 - Session is terminated when issuing a chown command
Session is terminated when issuing a chown command
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-02 11:40 EDT by John B. Wier III
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-02 11:41:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John B. Wier III 2002-06-02 11:40:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Win98; U)

Description of problem:
cd /tmp and issue touch testfile as root. Then issue chown <user_id> testfile. The session is terminated immediately and the file was not changed. 
If you issue a fully qualified /bin/chown, it works just fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd /tmp
2. touch testfile
3. chown testfile <user_id>
	

Actual Results:  The logged in session is terminated immediately.

Expected Results:  The ownership of the file should have been changed to the new user_id

Additional info:

standard i686 smp kernel
dual Pentium 1.13MHZ on Tyan Tiger 2507 MB
768MB RAM
ATI Rage 128 Pro AGP graphics card
3 IDE drives
1 IDE CD-RW
adaptec 2940UW PRO SCSI controller
1 SCSI CD-RW
1 SCSI tape drive
1 Linksys 100 LAN card
SoundBlaster 5.1 !Live
US Robotics internal PCI modem

This is on a fresh 7.3 install from CD - custom install choosing everything.
Comment 1 Bernhard Rosenkraenzer 2002-06-02 11:48:55 EDT
Huh?  
  
[root@locutus root]# cd /tmp  
[root@locutus tmp]# touch testfile  
[root@locutus tmp]# chown bero testfile  
[root@locutus tmp]# ls -l testfile  
-rw-r--r--    1 bero     root            0 Jun  2 17:47 testfile 
 
  
Looks like someone cracked your machine and either put an "alias chmod=logout" 
in your startup scripts, or put an alternate chown doing evil things in a 
location earlier on in the PATH than /bin. 
 
You can figure out which chown is being executed by typing "which chown". 

Note You need to log in before you can comment on or make changes to this bug.