Bug 658466 - [abrt] evolution-2.28.3-10.el6: g_slice_alloc: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-2.28.3-10.el6: g_slice_alloc: Process /usr/bin/evolution was...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-30 13:13 UTC by Siddharth
Modified: 2018-10-27 11:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-17 14:15:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
backtrace, disassembly (48.64 KB, text/plain)
2010-11-30 13:14 UTC, Siddharth
no flags Details
coredump (9.30 MB, application/x-bzip)
2010-11-30 13:17 UTC, Siddharth
no flags Details

Description Siddharth 2010-11-30 13:13:52 UTC
Description of problem:
evolution-2.28.3-10.el6: g_slice_alloc: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)

How reproducible:
Random

Actual results:
Evolution is getting crash.

Expected results:
It should not crash.

Additional info:
Backtrace, coredump attached.

Comment 1 Siddharth 2010-11-30 13:14:55 UTC
Created attachment 463719 [details]
backtrace, disassembly

Comment 2 Siddharth 2010-11-30 13:17:57 UTC
Created attachment 463721 [details]
coredump

Comment 3 Siddharth 2010-11-30 13:18:26 UTC
Created attachment 463723 [details]
sosreport

Comment 5 Milan Crha 2010-12-01 08:05:38 UTC
Thanks for a bug report. This is crashing somewhere in pango, which might mean either bug in there or some memory corruption caused by Evolution or other library it is using.

Main question is whether you are able to reproduce this. Are you? Because if so, then I would try to run evolution under valgrind and see what it'll show, because it may uncover that memory corruption. I would run valgrind like this:
   $ G_SLICE=always-malloc valgrind --num-callers=50 evolution &>evo.log

Evolution will be very slow, due to all memory checking, but it may show results at the end. Please give this a try and report back. Thanks in advance.

Thread 1 (Thread 4483):
#0  magazine_chain_pop_head (mem_size=16) at gslice.c:474
        chunk = 0x1
#1  thread_memory_magazine1_alloc (mem_size=16) at gslice.c:777
#2  IA__g_slice_alloc (mem_size=16) at gslice.c:815
#3  0x0000003cf2457df6 in IA__g_slist_append (list=0x0, data=0x24fb610) at gslist.c:117
#4  0x0000003cfb42027f in reorder_runs_recurse (items=<value optimized out>, n_items=1) at pango-layout.c:4758
#5  0x0000003cfb421dd7 in pango_layout_line_reorder (layout=0x2584f10) at pango-layout.c:4786
#6  pango_layout_line_postprocess (layout=0x2584f10) at pango-layout.c:5186
#7  process_line (layout=0x2584f10) at pango-layout.c:3587
#8  pango_layout_check_lines (layout=0x2584f10) at pango-layout.c:3850

Comment 7 RHEL Program Management 2011-01-17 14:15:30 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.