This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 658493 - Running oo* from a terminal finishes immediately, no job
Running oo* from a terminal finishes immediately, no job
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 09:32 EST by Horst H. von Brand
Modified: 2011-01-06 10:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-06 10:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2010-11-30 09:32:13 EST
Description of problem:
Now OOo programs finish immediately when run from a terminal. This is a change respect to the earlier behaviour, and (as this is usually a symptom on something gone awry) it scares me a bit... plus it doesn't show up as a program in my session.

Version-Release number of selected component (if applicable):
libreoffice-3.2.99.3-2.fc15.x86_64

How reproducible:
Each time an OOo program is started

Steps to Reproduce:
1. oocalc (or oowriter). Haven't really tried others.
2.
3.
  
Actual results:
Finishes immediately, a bit scary... ps(1)  or bahs(1)'s jobs doesn't show it

Expected results:
Don't go to background unless '&'. Besides, how am I supposed to kill a misbehaving OOo program if "kill %1" doesn't?

Additional info:
Comment 1 Caolan McNamara 2010-11-30 09:38:22 EST
It runs though, right ?, i.e. LibreOffice appears and works fine. i.e. we're talking about the splashscreen as separate app feature to get the splash up and showing as fast as possible.
Comment 2 Horst H. von Brand 2010-12-05 18:42:40 EST
Yes, oocalc (or whatever)'s window shows up eventually. There is no splash screen at all that I see.

It used to work by not going to the background at all (nor showing a splashscreen here)
Comment 3 Caolan McNamara 2010-12-06 04:08:37 EST
You're confusing me a little as to what the bug is.

a) Do you have the quickstarter running ?, i.e. in the panel. If you do then that's why there's no splash screen when launching something again.

I don't think there's any bug here, but I'm willing to be convinced otherwise.
Comment 4 Horst H. von Brand 2010-12-14 10:30:21 EST
OK, yes. I do have the icon on the panel.

Perhaps not a bug per se, but a surprising (to me) change

Thanks for your time!

Note You need to log in before you can comment on or make changes to this bug.