Bug 658531 - anaconda crashes setting timezone at end of update
Summary: anaconda crashes setting timezone at end of update
Keywords:
Status: CLOSED DUPLICATE of bug 691263
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-30 16:32 UTC by Laurie Moye
Modified: 2011-03-31 18:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-31 18:22:04 UTC


Attachments (Terms of Use)

Description Laurie Moye 2010-11-30 16:32:49 UTC
Description of problem:
Updating installation installs all packages then aborts whilst trying to set
/etc/localtime

Version-Release number of selected component (if applicable):
Seems to occur in with anaconda in f12, f13, and f14, but not f11

How reproducible:
install fedora13 from DVD then attempt update with customised packages, or even with exactly the same packages.


Steps to Reproduce:
1. Install f13
2. update same partition with same or different packages
3. goes through the "installed n out of m" bit then aborts
  
Actual results:
anaconda aborts

Expected results:
anaconda completes

Additional info:
This seems to be the same bug as reported for f12 as 621979 and for
f14 as 650565.
When the system is first installed, usr/share/zoneinfo/Europe/London, for example, is hard linked to /etc/localtime.
At the end of update, anaconda tries to set /etc/localtime, as far as I can see, by copying the zoneinfo file to localtime. It crashes when it sees it is trying to copy the file onto itself.
In f11, the initial installation does not create a hard link (same inode), but a copy (different inode):

Current system is fedora11:
tosh/root/root: ll -i /etc/localtime
514150 -rw-r--r--. 1 root root 3661 2009-01-27 18:04 /etc/localtime
tosh/root/root: ll -i /usr/share/zoneinfo/Europe/London
361227 -rw-r--r--. 7 root root 3661 2009-04-13 15:17 /usr/share/zoneinfo/Europe/London

/mnt/sda6 is fedora13:
tosh/root/root: ll -i /mnt/sda6/etc/localtime
415832 -rw-r--r--. 8 root root 3661 2010-04-19 18:07 /mnt/sda6/etc/localtime
tosh/root/root: ll -i /mnt/sda6/usr/share/zoneinfo/Europe/London
415832 -rw-r--r--. 8 root root 3661 2010-04-19 18:07 /mnt/sda6/usr/share/zoneinfo/Europe/London

I'm sorry, my browser (Opera) won't allow me to write anything in the attachment window, so I've copied the relevant part of the anaconda exceptions report below.
------------------------------------------------------------------------
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/shutil.py", line 47, in copyfile
    raise Error, "`%s` and `%s` are the same file" % (src, dst)
  File "/usr/lib/anaconda/timezone.py", line 42, in write
    shutil.copyfile(fromFile, instPath + "/etc/localtime")
  File "/usr/bin/anaconda", line 696, in write
    self.timezone.write(self.rootPath)
  File "/usr/lib/anaconda/backend.py", line 313, in writeConfiguration
    anaconda.write()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1334, in handleRenderCallback
    self.currentWindow.renderCallback()
Error: `/mnt/sysimage/usr/share/zoneinfo/Europe/London` and `/mnt/sysimage/etc/localtime` are the same file

Comment 1 Chris Lumens 2011-03-31 18:22:04 UTC

*** This bug has been marked as a duplicate of bug 691263 ***


Note You need to log in before you can comment on or make changes to this bug.