Bug 65855 - Couldn't "Switchdesk" from "Windowmaker" to any other GUI
Summary: Couldn't "Switchdesk" from "Windowmaker" to any other GUI
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: switchdesk (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-02 23:47 UTC by Walter
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-02 23:48:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Walter 2002-06-02 23:47:14 UTC
Description of Problem:
I normally use the Gnome GUI and boot into shell. I "startx" to my GUI.
I used "switchdesk" to try out the "Windowmaker" GUI and could not "switchdesk" 
into any other GUI. It would always "startx" into "Windowmaker".
From shell, I tried "switchdesk kde", and "switchdesk gnome", and neither would 
start. It appeared that they were trying to start, but them the destop would 
always switch into "Windowmaker". I was stuck with a Windowmaker-only GUI.
I tried switching from within "windowmaker", but that didn't work either.

To solve the problem I had to use "windowmaker" to edit my config file in my
"root" folder to remove the "wmaker" entry and change it to start "Gnome". 
Time to fix - approximately 12 hours! 

Version-Release number of selected component (if applicable):
I'm not currently in "root", so I don't the version's involved - but I have all 
the latest Red Hat updates except for the most recent Kernal. 
I am using kernal 2.4.18-3.
I don't remember the file I had to edit to fix the problem at the moment, and I 
can't look at my "root" directory now because I'm not logged in as root.
I imagine most anyone more familiar with Linux than I would probably know 
what file I had to edit.

How Reproducible:
I don't dare even try to "switchdesk" to anything else!

Steps to Reproduce:
1. I don't dare try
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Karsten Hopp 2002-08-06 12:55:16 UTC
I've tried that with the latest switchdesk, works without problems. 
Btw: switchdesk writes the files $HOME/.Xclients*, If you run into problems, 
remove them and run switchdesk again.


Note You need to log in before you can comment on or make changes to this bug.