Bug 658576 - unoconv assumes soffice is installed, but does not Require
Summary: unoconv assumes soffice is installed, but does not Require
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: unoconv
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-30 18:26 UTC by Ben Boeckel
Modified: 2011-04-14 20:12 UTC (History)
2 users (show)

Fixed In Version: unoconv-0.4-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-19 20:20:38 UTC


Attachments (Terms of Use)

Description Ben Boeckel 2010-11-30 18:26:03 UTC
Description of problem:
% unoconv -vvv -l
Verbosity set to level 2
Start listener on localhost:2002
Warning: trying to launch soffice.bin.
Warning: trying to launch soffice.
Error: Failed to start listener on localhost:2002

Please add a Requires: openoffice.org-brand to unoconv.

Version-Release number of selected component (if applicable):
unoconv-0.3-4.fc12.noarch

(F14 here)

Comment 1 Ben Boeckel 2010-11-30 18:32:57 UTC
Looking at libreoffice, soffice is in libreoffice-core.

Comment 2 Orcan Ogetbil 2010-11-30 18:53:26 UTC
Hi did you try the latest version of unoconv from updates-testing?

Comment 3 Ben Boeckel 2010-11-30 19:07:51 UTC
The dependency is still missing. I get this (better than needing -vvv):

unoconv: Cannot find the soffice binary in sys.path and known paths.

Update output from yum shell:

> remove openoffice.org-brand
Setting up Remove Process
> install unoconv
Setting up Install Process
> run
--> Running transaction check
---> Package openoffice.org-brand.x86_64 1:3.3.0-15.2.fc14 set to be erased
---> Package unoconv.noarch 0:0.4-2.fc14 set to be updated
--> Finished Dependency Resolution

<snip>

Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : unoconv-0.4-2.fc14.noarch
  Erasing        : 1:openoffice.org-brand-3.3.0-15.2.fc14.x86_64
  Cleanup        : unoconv-0.3-4.fc12.noarch

Removed:
  openoffice.org-brand.x86_64 1:3.3.0-15.2.fc14

Updated:
  unoconv.noarch 0:0.4-2.fc14

Finished Transaction

Comment 4 Orcan Ogetbil 2010-11-30 19:18:03 UTC
Alright. Thanks for the report. I'll add the necessary Requires.

Comment 5 Fedora Update System 2010-11-30 23:23:41 UTC
unoconv-0.4-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/unoconv-0.4-3.fc14

Comment 6 Fedora Update System 2010-12-01 21:55:42 UTC
unoconv-0.4-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update unoconv'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/unoconv-0.4-3.fc14

Comment 7 Fedora Update System 2010-12-19 20:20:33 UTC
unoconv-0.4-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Ben Boeckel 2011-04-14 20:12:32 UTC
Hmm. Since OO.o (and libreoffice I would assume) support a server/client model, I wonder if there shouldn't be a "core" package which doesn't bring in dependencies and then the base package enforces the dependencies.


Note You need to log in before you can comment on or make changes to this bug.