Bug 658679 - SELinux is preventing /usr/bin/gnome-screensaver "getattr" access on /usr/bin/consolehelper.
Summary: SELinux is preventing /usr/bin/gnome-screensaver "getattr" access on /us...
Keywords:
Status: CLOSED DUPLICATE of bug 647588
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:abfed8cf80a...
: 658680 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-01 00:31 UTC by mdeggers
Modified: 2010-12-08 07:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-01 10:09:09 UTC
Type: ---


Attachments (Terms of Use)

Description mdeggers 2010-12-01 00:31:47 UTC
Summary:

SELinux is preventing /usr/bin/gnome-screensaver "getattr" access on
/usr/bin/consolehelper.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gnome-screensav. It is not expected that this
access is required by gnome-screensav and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:consolehelper_exec_t:s0
Target Objects                /usr/bin/consolehelper [ file ]
Source                        gnome-screensav
Source Path                   /usr/bin/gnome-screensaver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-screensaver-2.30.2-2.fc14
Target RPM Packages           usermode-1.106.1-1.fc14
Policy RPM                    selinux-policy-3.9.7-12.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.6-48.fc14.i686
                              #1 SMP Fri Oct 22 15:34:36 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Mon 29 Nov 2010 08:29:34 PM PST
Last Seen                     Mon 29 Nov 2010 08:29:34 PM PST
Local ID                      f6c80b58-2912-4bba-b1b2-1d44af452ffb
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291091374.724:49): avc:  denied  { getattr } for  pid=1939 comm="gnome-screensav" path="/usr/bin/consolehelper" dev=dm-0 ino=779195 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:consolehelper_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1291091374.724:49): arch=40000003 syscall=195 success=yes exit=0 a0=9d8f524 a1=bfd357e0 a2=aecff4 a3=4 items=0 ppid=1 pid=1939 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="gnome-screensav" exe="/usr/bin/gnome-screensaver" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gnome-screensav,xdm_t,consolehelper_exec_t,file,getattr
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t consolehelper_exec_t:file getattr;

Comment 1 Miroslav Grepl 2010-12-01 09:03:18 UTC
*** Bug 658680 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-12-01 10:09:09 UTC
What does the following command say

# ps auxZ | grep screensaver

*** This bug has been marked as a duplicate of bug 647588 ***


Note You need to log in before you can comment on or make changes to this bug.