Bug 65869 - apmscript behaves badly when running anacron
apmscript behaves badly when running anacron
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-03 10:51 EDT by Garrett Mitchener
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.0.2-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 16:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Garrett Mitchener 2002-06-03 10:51:41 EDT
Description of Problem:

This is an enhancement request.  Could you please use the -s flag when running
anacron in /etc/sysconfig/apm-scripts/apmscript?  Everything works as is, but I
have a terrible time using my computer when I turn it on first thing in the
morning because it runs anacron which runs the tripwire check and my backup
script at the same time and the system slows to a crawl.  I've added -s (which
means run jobs sequentially rather than all at once) to fix this in my personal
copy of the file, but I'm sure other people would appreciate this small change.
Comment 1 Jens Petersen 2002-08-23 07:02:59 EDT
Sounds sensible to me.
Comment 2 Jens Petersen 2002-08-23 07:28:12 EDT
But run-parts serializes the execution of cron jobs anyway,
so I don't really know how much affection this would have?
Comment 3 Garrett Mitchener 2002-08-26 22:00:44 EDT
The reason this is a problem on my system is that my backup script runs weekly,
but updatedb and tripwire run daily.  Once a week, anacron will use run-parts on
the daily and weekly jobs at the same time.
Comment 4 Jens Petersen 2002-08-28 06:44:51 EDT
In anacron-2.3-23 /etc/init.d/anacron now starts anacron with the "-s"
option and at nice level 19.  It would probably be good if apmd did the
same.  Perhaps it could just be made to run "/etc/init.d/anacron"?

I can make this change if you like, bero?
Comment 5 Jens Petersen 2002-09-09 07:25:49 EDT
Assigning this to myself for now.
Comment 6 Bill Nottingham 2003-05-19 16:54:43 EDT
Added in 3.0.2-19.

Note You need to log in before you can comment on or make changes to this bug.