Bug 658728 - Ibus can't support Chinese normally when chat with others
Ibus can't support Chinese normally when chat with others
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 23:49 EST by Zhouping Liu
Modified: 2014-01-12 19:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 02:59:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhouping Liu 2010-11-30 23:49:29 EST
Description of problem:
when I translate some Chinese words using ibus tools in website,especially some chat websites such as Gtalk, QQ and web.qq , it always can't display the Chinese words, and the occur just flicker and flicker.  

Version-Release number of selected component (if applicable):
fedora13 and RHEL6(RC4) 

How reproducible:


Steps to Reproduce:
1.setup the ibus on Chinese status
2.chat with friends using Gtalk or web.qq chat-tools or others, and chat with Chinese language.  
3.
  
Actual results:
a several minutes later, the ibus wouldn't support Chinese, but flicker again and again when using it.

Expected results:
no this phenomemon

Additional info:
when the error happened, you can restart ibus, it will okay, but it also wrong some times when you restart it several times.
the bug don't happen every times when you try to reproduce it.
Comment 1 Simon Yan 2010-12-01 04:56:25 EST
Does this happen when you use native Chatting applications?
Does this happen if you do a long time Chinese typing in other forms of input on a website? Like writing a blog entry.
What's the browser you are using and can you reproduce this problem if you change to a different browser?
Comment 2 Zhouping Liu 2010-12-01 06:17:03 EST
(In reply to comment #1)
> Does this happen when you use native Chatting applications?
Sorry,I didn't use native Chatting applications, but I haven't found this error when I did Chinese typing in local, such as gedit, vim, etc.
> Does this happen if you do a long time Chinese typing in other forms of input
> on a website? Like writing a blog entry.
yes.
> What's the browser you are using and can you reproduce this problem if you
> change to a different browser?
firefox, version 3.6.10, I didn't use other browser, but I can try to reproduce it on Google Chrome browser. if I can reproduce it, I will update the comment on time.
Comment 3 Piotr Drąg 2010-12-14 08:33:29 EST
I think it's more like ibus issue than localization issue. Moving to Fedora/ibus component.
Comment 4 Simon Yan 2010-12-14 09:36:14 EST
Were you able to try this in Fedora 14?





-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Zhouping Liu 2010-12-14 20:13:35 EST
(In reply to comment #4)
> Were you able to try this in Fedora 14?
> 
I just reproduced it on Fedora 13 and RHEL6, since I didn't using Fedora 14 system. I can have a try  on Fedora 14 .

thanks.
Comment 6 fujiwara 2010-12-14 20:40:26 EST
> (In reply to comment #5)
> I can have a try  on Fedora 14 .

Yes, it's better to use Fedora 14.

Also the latest is ibus-1.3.9-1 .
You could update the ibus:
yum --enablerepo=updates-testing update ibus


I cannot reproduce your problem. I can use ibus-pinyin on Gtalk and GEdit.
Comment 7 fujiwara 2011-02-03 04:56:56 EST
zliu:

Do you have any updates?
Comment 8 Zhouping Liu 2011-02-21 00:28:09 EST
(In reply to comment #7)
> zliu:
> 
> Do you have any updates?
Sorry, I'm late,  it also occurred on Fedora 14, and the web.qq.com may help you reproduce it easily (you need a QQ account and chat with your friends).
Comment 9 fujiwara 2011-02-22 23:25:54 EST
(In reply to comment #8)
> Sorry, I'm late,  it also occurred on Fedora 14, and the web.qq.com may help
> you reproduce it easily (you need a QQ account and chat with your friends).

The web.qq.com is a bit difficult for me since I cannot read the Chinese registration and maybe it needs another account to chat.
The top page on web.qq.com shows a search box and I don't see any problems with ibus-pinyin.

Are you able to attach the screenshot to show your problem?

% gnome-screenshot --delay 5

Also which key sequences are typed to reproduce your problem with ibus-pinyin?
I can try gtalk on firefox 3.6.13

Note You need to log in before you can comment on or make changes to this bug.