Bug 658747 - unetbootin fails to initialize when started from root
Summary: unetbootin fails to initialize when started from root
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: unetbootin
Version: 14
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 671044 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-01 06:29 UTC by David M.
Modified: 2011-01-20 09:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-01 07:41:16 UTC


Attachments (Terms of Use)

Description David M. 2010-12-01 06:29:27 UTC
Description of problem:  unetbootin aborts immediately after launched by root user.


Version-Release number of selected component (if applicable): 

Name        : unetbootin
Arch        : x86_64
Version     : 0
Release     : 8.494bzr.fc14



How reproducible: always


Steps to Reproduce:
1.  Open up terminal
2.  type 'su' and enter password to gain root privileges
3.  type 'unetbootin'
  
Actual results:

Unetbootin aborts in less than one second after launch.

Expected results:

Unetbootin should start normally.

Additional info:

This is all the feedback I get when trying to start unetbootin:

# unetbootin 
**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted (core dumped)


Please let me know how if you need any additional information.  And if so, where I can get it.

Comment 1 Susi Lehtola 2010-12-01 07:41:16 UTC
Use su as you're supposed to:
 $ su -
instead of 
 $ su
The former will also change the environment variables to those of the root user.

Comment 2 David M. 2010-12-01 19:45:16 UTC
Yup, that fixed it.  Thank you for the quick response.  I've never had to add the "-" in older versions of unetbootin.


-Dave

Comment 3 Susi Lehtola 2011-01-20 09:57:08 UTC
*** Bug 671044 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.