Bug 658758 - [abrt] machineball-1.0-9.fc13: _xwin_signal_handler: Process /usr/bin/machineball was killed by signal 6 (SIGABRT)
Summary: [abrt] machineball-1.0-9.fc13: _xwin_signal_handler: Process /usr/bin/machine...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alleggl
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7d6ba2c178346c3635fd8a32f3c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-01 07:36 UTC by Ivelin Djantov
Modified: 2010-12-09 22:01 UTC (History)
1 user (show)

Fixed In Version: alleggl-0.4.3-8.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-09 22:01:39 UTC


Attachments (Terms of Use)
File: backtrace (15.27 KB, text/plain)
2010-12-01 07:36 UTC, Ivelin Djantov
no flags Details

Description Ivelin Djantov 2010-12-01 07:36:30 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: machineball
component: machineball
crash_function: _xwin_signal_handler
executable: /usr/bin/machineball
kernel: 2.6.34.7-61.fc13.i686
package: machineball-1.0-9.fc13
rating: 4
reason: Process /usr/bin/machineball was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
time: 1291188922
uid: 500

How to reproduce
-----
1. I started the game
2. Black screen appeared for a second
3. I saw my desktop again

Comment 1 Ivelin Djantov 2010-12-01 07:36:32 UTC
Created attachment 463916 [details]
File: backtrace

Comment 2 Hans de Goede 2010-12-01 08:24:36 UTC
Hmm, this is caused by your libGL returning NULL as renderer string which is rather weird. Anyways I've created an update for alleggl (where the crash is) dealing with the NULL renderer string. Please give it a test once it hits updates-testing.

Comment 3 Fedora Update System 2010-12-01 08:29:10 UTC
alleggl-0.4.3-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/alleggl-0.4.3-8.fc14

Comment 4 Fedora Update System 2010-12-01 08:29:35 UTC
alleggl-0.4.3-8.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/alleggl-0.4.3-8.fc13

Comment 5 Fedora Update System 2010-12-01 22:01:02 UTC
alleggl-0.4.3-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update alleggl'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/alleggl-0.4.3-8.fc13

Comment 6 Fedora Update System 2010-12-09 22:01:34 UTC
alleggl-0.4.3-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-12-09 22:01:46 UTC
alleggl-0.4.3-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.