Bug 65876 - RHR Cert Suite audio failure on Dell WS340
RHR Cert Suite audio failure on Dell WS340
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-03 12:29 EDT by Rogelio Noriega
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-12 10:53:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhr cert suite dsp.out file (7.18 KB, patch)
2002-06-03 12:30 EDT, Rogelio Noriega
no flags Details | Diff

  None (edit)
Description Rogelio Noriega 2002-06-03 12:29:19 EDT
Description of Problem:
Dell WS340 on-board audio i810 fails rhr audio cert, midi test fails no audio 
is played but systems plays midi files perfectly using kmidi. Cert 
reports /dev/sequencer: No such device but it does exist.

Begin Midi Audio Playback Test
open /dev/sequencer: No such device
Error playing midi sound.
Midi Audio Playback Test Complete

also when wav files are played or sndconfig ran several message are displayed 
on the console. see below and attached logs.

PCI: Setting latency timer of device 00:1f.5 to 64
i810_audio: Audio Controller supports 6 channels.
i810_audio: AC'97 codec 0 Unable to map surround DAC's (or DAC's not present), 
total channels = 2
i810_audio: setting clocking to 41319

Version-Release number of selected component (if applicable):


How Reproducible:100%


Steps to Reproduce:
1. Run rhr cert suite for RH7.3
2. 
3. 

Actual Results:
Failed audio test RH7.3

Expected Results:
Pass audio cert.


Additional Information:
The certs suite fails but everything seems to functioning correctly, the only 
thing that bugs me is the debugging info being displayed to the console.
Comment 1 Rogelio Noriega 2002-06-03 12:30:45 EDT
Created attachment 59384 [details]
rhr cert suite dsp.out file
Comment 2 Rogelio Noriega 2002-06-12 10:53:43 EDT
The cert test records and plays back all the files, but still reports the test 
as failing see below is this a bug in the script?

sox: Sound card appears to only support 2 channels.  Overriding format
                                                             [FAILED]
Comment 3 Doug Ledford 2002-08-08 16:31:20 EDT
None of these are driver problems.  The "sox: Sound card appears to only support
2 channels.  Overriding format" is correct because the i810 hardware *does* only
support 2 channels (or more, later versions can go up to 6 channels, but *no*
i810 audio device supports mono playback which is what sox is attempting to
set).  The failure on the midi test is also correct because the i810 audio cards
do not have a hardware midi sequencer (aka, /dev/sequencer does not exist on the
card even if the file exists in /dev, so when you attempt to open /dev/sequencer
the kernel correctly tells you that there is no such device).  The only way to
play midi files on an i810 chipset machine is to use a software midi synthesizer
such as timidity or kmidi.  This is the correct way to play midi files on this
card and the test suite should reflect that.  I would open a separate issue
against the test suite, not against the kernel, if you need these things taken
care of.

Note You need to log in before you can comment on or make changes to this bug.