Bug 65878 - gdm shouldn't die with unresolvable name
gdm shouldn't die with unresolvable name
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-06-03 13:37 EDT by Jerry Quinn
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-06-03 13:37:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jerry Quinn 2002-06-03 13:37:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020421

Description of problem:
If a machine has a working network config, but the hostname does not
resolve, gdm refuses to start the xserver with:

gdm_auth_secure_display: Error getting hentry for <machinename>

In my particular case, this happens because we have a secure dynamic
dns update mechanism and I haven't configured it yet.  I can still
access the network and have a valid IP.

At best this is obscure and guaranteed to leave a newbie stumped.  Why should
the X server refuse to start because gdm can't resolve the hostname?  It can
still authenticate the user the same way the console can.

An error message at the graphic would be more appropriate.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Set up machine with a working network config, but an unresolvable
2. Watch gdm squirm

Actual Results:  As described above.

Expected Results:  Described above.

Additional info:
Comment 1 Havoc Pennington 2002-06-09 11:00:04 EDT
Bug posted on gnome.org at http://bugzilla.gnome.org/show_bug.cgi?id=84659 - you
may want to get on the cc list for that upstream bug.

We will get the fix if this is resolved upstream.

Note You need to log in before you can comment on or make changes to this bug.