Bug 65882 - '--help' and '--usage' cause "multiple segmentation faults"
'--help' and '--usage' cause "multiple segmentation faults"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
7.1
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-03 14:16 EDT by Ben Levenson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version: 2.0.2-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-30 00:27:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of "xchat --help" (29.76 KB, text/plain)
2002-06-03 14:17 EDT, Ben Levenson
no flags Details

  None (edit)
Description Ben Levenson 2002-06-03 14:16:33 EDT
Description of Problem:

[root@ia64-71 XCHAT-2002-097]# xchat --help
Multiple segmentation faults occurred; can't display error dialog

[root@ia64-71 XCHAT-2002-097]# xchat --usage
Multiple segmentation faults occurred; can't display error dialog
[root@ia64-71 XCHAT-2002-097]# echo $?
1

Version-Release number of selected component (if applicable):
This happens with the dist AND errata versions. I don't see this problem
on 7.2 versions.

xchat-1.6.3-4.ia64.rpm
xchat-1.8.7-1.71.0.ia64.rpm

How Reproducible:
100%

strace to follow.
Comment 1 Ben Levenson 2002-06-03 14:17:10 EDT
Created attachment 59406 [details]
strace of "xchat --help"
Comment 2 Mike A. Harris 2002-06-03 20:26:07 EDT
Multiple SEGV's?  Heh.  That sounds weird.
Only on ia64.. Hmm.

If I had to hazard a guess, I'd guess it is a compiler bug or somesuch, if
it works on 7.2 and not on 7.1.  I'll have a look sometime though.
Comment 3 Mike A. Harris 2002-07-23 06:07:46 EDT
xchat 1.8.9 is errata for all platforms now.  Does the problem still
exist on ia64 with the current xchat erratum release?
Comment 4 Mike A. Harris 2002-09-05 15:49:32 EDT
Not mission critical, defering for future.
Comment 5 Mike A. Harris 2003-05-14 07:10:35 EDT
I haven't had a chance to poke at this yet.  I'm hoping to go through all
open ia64 bugs soon though.
Comment 6 Mike A. Harris 2003-05-30 00:27:55 EDT
Seems to be working now, whatever it was.  Could have been a bug that is now
fixed in current bits, or perhaps a wonky kernel or something from days gone
by.

[root@katzj-ia64 root]# xchat --help
xchat 2.0.2
Usage: xchat [OPTIONS]... [URL]

Options:
  -d,  --cfgdir DIRECTORY   use a different config dir
  -a,  --no-auto            don't auto connect
  -v,  --version            show version information

URL:
  irc://server:port/channel


Reopen if the problem recurs.

Note You need to log in before you can comment on or make changes to this bug.