Bug 658823 - migration hang if terminating the destination qemu process
migration hang if terminating the destination qemu process
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On: 513765
Blocks: 545233 Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2010-12-01 07:26 EST by Eduardo Habkost
Modified: 2013-01-09 18:23 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 513765
Environment:
Last Closed: 2011-01-16 03:33:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Habkost 2010-12-01 07:26:22 EST
Cloning for the second issue mentioned on the report (quiting the dest VM).

+++ This bug was initially created as a clone of Bug #513765 +++

[...]
   Another phenomenon is : If quit dst vm. in src vm. QEMU cmd 'info migrate ' show migration still running. the value of _transferred ram_ and _total ram_ stuck. while the value of _remaining ram_ increase . e.g. ( in this testing, we just used 128G RAM )

--- Additional comment from bcao@redhat.com on 2010-11-30 22:23:23 EST ---

Referring to comment#0
Another phenomenon is : If quit dst vm. in src vm. QEMU cmd 'info migrate '
show migration still running. the value of _transferred ram_ and _total ram_
stuck. while the value of _remaining ram_ increase . e.g. ( in this testing, we
just used 128G RAM )

re-test on kvm-83-217.el5

this issue still exists.the value of _transferred ram_ and _total ram_
stuck._remaining ram_ increase a little ,then stuck.

Expected Results:
'(qemu)info migration' should show migration failed.

Based on above ,re-assign this issue.

--- Additional comment from quintela@redhat.com on 2010-12-01 07:02:44 EST ---

eventually, state of migration will shown as failed.
it needs to detect that the other side have died.  This is not a regression, is something that has always been there.

opening other bugzilla for this is ok.
Comment 1 RHEL Product and Program Management 2011-01-11 15:10:38 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2011-01-11 17:57:09 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 3 Dor Laor 2011-01-16 03:33:59 EST
Agree that we need to handle it but it is too low priority.
Closing as won't fix.

Note You need to log in before you can comment on or make changes to this bug.