Bug 658972 - Corrupted emails: Mix of email address and subject shown in subject line
Summary: Corrupted emails: Mix of email address and subject shown in subject line
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: akonadi
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-01 18:03 UTC by MartinG
Modified: 2012-08-16 18:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 18:48:53 UTC
Type: ---


Attachments (Terms of Use)

Description MartinG 2010-12-01 18:03:30 UTC
Description of problem:
I get corrupted emails when using Kontact/KMail to access my IMAP account. 

Version-Release number of selected component (if applicable):
F14, using kdepimlibs-akonadi-4.5.3-2.fc14.x86_64, akonadi-1.4.1-2.fc14.x86_64

How reproducible:
I have had problems every time I have tried to use Kontact.

Steps to Reproduce:
1. Start Kontact (which will force Akonadi to start)
2. Check email
3. Go to INBOX or a subfolder
4. See strange things happening.
  
Actual results:
Today, I saw a mix of the subjectline and the email address of the sender shown in Kontact in the subject column, and "Unknown" as date.

Earlier, I have seen messages duplicate, having the same (correct) subject line, but with the message body containing some header info, and also the body of other emails.

Something must be very wrong.

I have had a warning earlier (from the startup of akonadi):
    [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist

which I "solved" by:
$ akonadictl stop
$ mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/
$ akonadictl start

The next start of Akonadi seemed to be quite okay, except for the following error:
    "akonadiserver" [out] "Error    : You can't use locks with log tables.

How can I debug this, without risking the loss of my IMAP email? Is there a known fix?

Btw, I did run Rawhide before F14 was released, then I kept my /home/ and did a fresh install of F14 stable.

Comment 1 Fedora End Of Life 2012-08-16 18:48:56 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.