Bug 658989 - Package is missing essential dependencies and requirements
Package is missing essential dependencies and requirements
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: drupal6-feeds (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Peter Borsa
Fedora Extras Quality Assurance
:
Depends On: 659005
Blocks: InsightReviews
  Show dependency treegraph
 
Reported: 2010-12-01 13:48 EST by Paul W. Frields
Modified: 2011-05-19 01:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 01:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2010-12-01 13:48:01 EST
Description of problem:

From bug 654047 (see comment 12): 
'''
The spec should have fixed these other problems:

* Use %global for the top-level definitions instead of %define

* Package should require php >= 5.2 as noted in its Drupal .info file --
although that's automatically met in Fedora it's not necessarily met elsewhere
(e.g. EL-5).

* Package should require drupal6-ctools

* Package should require drupal6-job_scheduler (not available in Rawhide or
F14, also not packaged as far as I know)

I'm reopening this bug since I can't remember how we deal with packages that
have been reviewed and added to git prematurely.
'''

This package now exists in a broken fashion in Rawhide, and should not be built or pushed elsewhere until these problems are fixed.  Specifically, the job_scheduler module is required for this package, and will need to be packaged, reviewed and accepted for this one to be properly fixed.
Comment 1 Peter Borsa 2010-12-01 14:24:56 EST
Oh yes, I have forgotten. I have just submitted the job_scheduler package. https://bugzilla.redhat.com/show_bug.cgi?id=659005
Comment 2 Paul W. Frields 2010-12-10 15:33:46 EST
The job_scheduler review is now approved in bug 659005.
Comment 3 Fedora Update System 2011-01-10 09:37:18 EST
drupal6-feeds-1.0-0.2.beta10.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/drupal6-feeds-1.0-0.2.beta10.fc14
Comment 4 Paul W. Frields 2011-01-27 08:40:00 EST
Update has moved because of editing:
https://admin.fedoraproject.org/updates/drupal6-feeds-1.0-0.4.beta10.fc14
Comment 5 Fedora Update System 2011-01-27 15:59:34 EST
drupal6-feeds-1.0-0.4.beta10.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update drupal6-feeds'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/drupal6-feeds-1.0-0.4.beta10.fc14
Comment 6 Paul W. Frields 2011-03-26 15:12:39 EDT
Is this getting pushed to stable at some point, so we can close this last bug against our tracker?
Comment 7 Peter Borsa 2011-03-27 09:09:56 EDT
I think this is stable, I am going to push it into stable repository. We can close this because Feeds is working flawlessly our testing/staging instance.
Comment 8 Paul W. Frields 2011-03-27 11:08:20 EDT
Great. Once the package gets pushed to stable, the bug will be closed by the updates system automatically, no need to worry about it. Thanks Peter!

Note You need to log in before you can comment on or make changes to this bug.