Bug 659084 - Test case failure: Connecting an external display as a clone of built-in display on Toshiba Qosmio F25
Summary: Test case failure: Connecting an external display as a clone of built-in disp...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-nv
Version: 5.6
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ben Skeggs
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-01 21:24 UTC by Vasiliy Sharapov
Modified: 2012-04-20 17:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Toshiba Qosmio F25-AV205
Last Closed: 2012-04-20 17:26:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
xorg.conf (584 bytes, text/plain)
2010-12-14 17:52 UTC, Vasiliy Sharapov
no flags Details
Xorg.0.log (44.17 KB, text/plain)
2010-12-14 17:53 UTC, Vasiliy Sharapov
no flags Details
Xorg.setup.log (1.21 KB, text/plain)
2010-12-14 17:53 UTC, Vasiliy Sharapov
no flags Details

Description Vasiliy Sharapov 2010-12-01 21:24:38 UTC
Filed from caserun

Version-Release number of selected component (if applicable):
RHEL5.6-Client-20101029.0

Steps to Reproduce: 

 1. Plug an external display into the port for it on the laptop you are
    testing.
 2. If the laptop has a video hotkey, press it. Otherwise, open a terminal and
    execute: "xrandr"



Actual results: 
Nothing happens

Expected results:
Both displays should show the same thing, should show the entire desktop area,
and should not be corrupted.

Additional info:
`xev' shows an XF86Display event, `lshal -m' shows a "ButtonPressed" event on "switch-videomode", `udevmonitor' and `tail -f /var/log/dmesg' show nothing, though IIRC they shouldn't.
Also the test says to run `xrandr' if there is no hotkey, but that changes nothing, I think. Does anyone know how to make an XF86Display event (or something of equal effect) on machines that don't have this hotkey? It would be really helpful in testing other laptops, though irrelevant to this bug. Thanks.

Comment 2 Vasiliy Sharapov 2010-12-14 17:52:53 UTC
Created attachment 468658 [details]
xorg.conf

Comment 3 Vasiliy Sharapov 2010-12-14 17:53:33 UTC
Created attachment 468659 [details]
Xorg.0.log

Comment 4 Vasiliy Sharapov 2010-12-14 17:53:57 UTC
Created attachment 468661 [details]
Xorg.setup.log

Comment 7 RHEL Program Management 2011-05-31 14:37:03 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 8 Adam Jackson 2012-04-20 17:26:27 UTC
No further hardware enablement updates are planned for RHEL5's X stack.  If the nouveau driver in RHEL6 has issues on this chipset, please file a new bug against RHEL6.


Note You need to log in before you can comment on or make changes to this bug.