Bug 659158 - SELinux is preventing /usr/bin/python "lock" access on /etc/selinux/targeted/modules/semanage.read.LOCK.
Summary: SELinux is preventing /usr/bin/python "lock" access on /etc/selinux/targ...
Keywords:
Status: CLOSED DUPLICATE of bug 659145
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0269416e976...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-02 01:39 UTC by maurizio
Modified: 2010-12-08 19:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-02 09:37:42 UTC
Type: ---


Attachments (Terms of Use)

Description maurizio 2010-12-02 01:39:25 UTC
Summary:

SELinux is preventing /usr/bin/python "lock" access on
/etc/selinux/targeted/modules/semanage.read.LOCK.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by /usr/share/syst. It is not expected that this
access is required by /usr/share/syst and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                mauricio:user_r:user_t:s0-s0:c0.c1023
Target Context                system_u:object_r:semanage_read_lock_t:s0
Target Objects                /etc/selinux/targeted/modules/semanage.read.LOCK [
                              file ]
Source                        /usr/share/syst
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.4-25.fc13
Target RPM Packages           selinux-policy-targeted-3.7.19-69.fc13
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.3-85.fc13.i686
                              #1 SMP Thu May 6 18:44:12 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Wed 01 Dec 2010 05:41:49 PM MST
Last Seen                     Wed 01 Dec 2010 05:41:49 PM MST
Local ID                      b31c1fe4-3a61-495c-9915-932e4d551e94
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291250509.465:40): avc:  denied  { lock } for  pid=2601 comm="/usr/share/syst" path="/etc/selinux/targeted/modules/semanage.read.LOCK" dev=dm-0 ino=60765 scontext=mauricio:user_r:user_t:s0-s0:c0.c1023 tcontext=system_u:object_r:semanage_read_lock_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1291250509.465:40): arch=40000003 syscall=143 success=yes exit=0 a0=f a1=6 a2=791424 a3=5 items=0 ppid=2583 pid=2601 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="/usr/share/syst" exe="/usr/bin/python" subj=mauricio:user_r:user_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,/usr/share/syst,user_t,semanage_read_lock_t,file,lock
audit2allow suggests:

#============= user_t ==============
allow user_t semanage_read_lock_t:file lock;

Comment 1 Miroslav Grepl 2010-12-02 09:37:42 UTC

*** This bug has been marked as a duplicate of bug 659145 ***


Note You need to log in before you can comment on or make changes to this bug.