Bug 659166 - Error tryin to start gedit from shell as root
Error tryin to start gedit from shell as root
Status: CLOSED DUPLICATE of bug 650644
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
14
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-01 21:15 EST by pajafumo
Modified: 2010-12-03 05:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 05:29:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pajafumo 2010-12-01 21:15:57 EST
Description of problem:
Error trying to start gedit from shell


Version-Release number of selected component (if applicable):


How reproducible:
just type as root: gedit [file_path]

Steps to Reproduce:
1.start shell as root
2.type gedit [file_path]
3.enter
  
Actual results:
(gedit:2462): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Abortado (`core' generado)


Expected results:
open files with gedit

Additional info:
Comment 1 Brendan Jones 2010-12-02 03:17:39 EST
How did you start your root shell?

I have no problems starting root shell using 'su -' rather than simply 'su' which makes sense.







-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Andre Robatino 2010-12-03 03:31:57 EST
This is essentially the same as bug 650644. I don't know if that's the first report since its Status is also NEW. I do know that the "su -" requirement is new to F14 since I walk my father through using gedit to edit grub.conf each release and F14 is the first time plain old "su" didn't work.
Comment 3 Brendan Jones 2010-12-03 05:29:54 EST
You are right - it is the same bug. Has also been noted on the wiki here:  https://fedoraproject.org/wiki/Common_F14_bugs#su_gnome. Thanks for report. Closing as duplicate.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 650644 ***

Note You need to log in before you can comment on or make changes to this bug.