Bug 659187 - [abrt] java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14: os::abort: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
Summary: [abrt] java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14: os::abort: Process /usr/li...
Keywords:
Status: CLOSED DUPLICATE of bug 684774
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4315945cd64026d81cf33335bad...
: 659400 659721 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-02 05:54 UTC by Antoine Martin
Modified: 2012-03-20 16:06 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-20 16:06:03 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (211.21 KB, text/plain)
2010-12-02 05:54 UTC, Antoine Martin
no flags Details
eclipse crash report (107.87 KB, text/plain)
2010-12-02 18:28 UTC, Antoine Martin
no flags Details
backtrace of browser plugin crash (71.75 KB, text/plain)
2010-12-02 21:04 UTC, Kvikende
no flags Details

Description Antoine Martin 2010-12-02 05:54:08 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/java -Xms128m -Xmx384m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:-UseCompressedOops -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar -exitdata a40024 -vm /usr/bin/java -vmargs -Xms128m -Xmx384m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:-UseCompressedOops -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v2
comment: Use Eclipse.
component: java-1.6.0-openjdk
crash_function: os::abort
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
kernel: 2.6.35.6-48.fc14.x86_64
package: java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14
rating: 3
reason: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1291267707
uid: 500

How to reproduce
-----
1. Start Eclipse
2. It crashes soon after (sometimes..)

Comment 1 Antoine Martin 2010-12-02 05:54:23 UTC
Created attachment 464167 [details]
File: backtrace

Comment 2 Kvikende 2010-12-02 12:23:50 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I went to my University's Fronter page.
2. Opened my Email box there, and tried to open an email
3. Firefox seemed to hang, so I closed it

Comment
-----
I have the memcpy Linus provided in the bug where adobe flash had distorted sound on Fedora which fixes adobe flash.

Comment 3 Deepak Bhole 2010-12-02 14:24:08 UTC
Can you reproduce this consistently?

Comment 4 Deepak Bhole 2010-12-02 14:24:25 UTC
(In reply to comment #2)
> Package: java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14
> Architecture: x86_64
> OS Release: Fedora release 14 (Laughlin)
> 
> 
> How to reproduce
> -----
> 1. I went to my University's Fronter page.
> 2. Opened my Email box there, and tried to open an email
> 3. Firefox seemed to hang, so I closed it
> 
> Comment
> -----
> I have the memcpy Linus provided in the bug where adobe flash had distorted
> sound on Fedora which fixes adobe flash.

I think you've posted in the wrong bug by mistake.

Comment 5 Antoine Martin 2010-12-02 14:31:43 UTC
> Can you reproduce this consistently?

Well, it has crashed on me about 10 times today, so I guess that makes it kind of consistent. But it is not always during startup, sometimes it will work for a few hours before crashing... Just applied an openjdk system update, we'll see if that helps.

Comment 6 Deepak Bhole 2010-12-02 18:21:53 UTC
Does it happen with the new OpenJDK update as well? If so, can you please start eclipse from command line till it crashes, and then post the hs_err* file it from the launch directory?

Comment 7 Deepak Bhole 2010-12-02 18:25:34 UTC
*** Bug 659400 has been marked as a duplicate of this bug. ***

Comment 8 Antoine Martin 2010-12-02 18:27:21 UTC
Yes, it has crashed at least twice since the OpenJDK update.

The hs_err* files get dropped in $HOME, I'm attaching one.

Comment 9 Antoine Martin 2010-12-02 18:28:41 UTC
Created attachment 464322 [details]
eclipse crash report

Comment 10 Deepak Bhole 2010-12-02 19:31:41 UTC
The logs unfortunately do not contain enough information to debug the issue, which means we will have to find a way to reproduce this locally.

Does it crash without any projects open in Eclipse?

Comment 11 Antoine Martin 2010-12-02 20:13:15 UTC
I've seen it crash when seemingly nothing is happening at all.
(ie: it's on virtual desktop 3, and I haven't looked at it for hours)

I don't know about "without any projects" because I spend 99% of my time with eclipse open. I will try to leave it running on empty later today.

Comment 12 Kvikende 2010-12-02 20:36:23 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Package: java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14
> > Architecture: x86_64
> > OS Release: Fedora release 14 (Laughlin)
> > 
> > 
> > How to reproduce
> > -----
> > 1. I went to my University's Fronter page.
> > 2. Opened my Email box there, and tried to open an email
> > 3. Firefox seemed to hang, so I closed it
> > 
> > Comment
> > -----
> > I have the memcpy Linus provided in the bug where adobe flash had distorted
> > sound on Fedora which fixes adobe flash.
> 
> I think you've posted in the wrong bug by mistake.

Then it must be abrt bug, as I just answered the questions in the abrt screen. I remember this happened when Firefox hanged, so I closed Firefox to reopen it and abrt said Java crashed. I have the backtrace if you're interested.

Comment 13 Deepak Bhole 2010-12-02 20:45:24 UTC
(In reply to comment #12)
> 
> Then it must be abrt bug, as I just answered the questions in the abrt screen.
> I remember this happened when Firefox hanged, so I closed Firefox to reopen it
> and abrt said Java crashed. I have the backtrace if you're interested.

Sure! Please attach it to this bug. If it is a separate issue, I will open another bug.

Comment 14 Kvikende 2010-12-02 21:04:41 UTC
Created attachment 464371 [details]
backtrace of browser plugin crash

Here it is. Thanks for your friendliness :D

Comment 15 Deepak Bhole 2010-12-03 16:58:06 UTC
*** Bug 659721 has been marked as a duplicate of this bug. ***

Comment 16 Antoine Martin 2010-12-05 19:22:55 UTC
Finally crashed again, this got filed as a new bug though: #660136

To be fair, I am used to having eclipse crash every few days, I can live with that. It was the constant crashes that made me report this bug.

Comment 17 abrt-bot 2012-03-20 16:06:03 UTC
Backtrace analysis found this bug to be similar to bug #684774, closing as duplicate.

Bugs which were found to be similar to this bug: bug #650146, bug #662401, bug #684774

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 684774 ***


Note You need to log in before you can comment on or make changes to this bug.