Bug 659199 - SELinux is preventing /bin/bash "read" access on /root/.bash_history.
Summary: SELinux is preventing /bin/bash "read" access on /root/.bash_history.
Keywords:
Status: CLOSED DUPLICATE of bug 659145
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b81d5486bd9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-02 06:46 UTC by maurizio
Modified: 2010-12-02 09:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-02 09:38:39 UTC
Type: ---


Attachments (Terms of Use)

Description maurizio 2010-12-02 06:46:45 UTC
Summary:

SELinux is preventing /bin/bash "read" access on /root/.bash_history.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by bash. It is not expected that this access is
required by bash and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                mauricio:user_r:user_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root/.bash_history [ file ]
Source                        bash
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.1.2-4.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34.7-61.fc13.i686
                              #1 SMP Tue Oct 19 04:42:47 UTC 2010 i686 i686
Alert Count                   3
First Seen                    Wed 01 Dec 2010 11:22:38 PM MST
Last Seen                     Wed 01 Dec 2010 11:30:03 PM MST
Local ID                      7662d3a4-b703-42ca-a8f6-55a539f1493b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291271403.565:25534): avc:  denied  { read } for  pid=2279 comm="bash" name=".bash_history" dev=dm-0 ino=61694 scontext=mauricio:user_r:user_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1291271403.565:25534): arch=40000003 syscall=5 success=yes exit=3 a0=81cee10 a1=8000 a2=0 a3=81cee10 items=0 ppid=2265 pid=2279 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="bash" exe="/bin/bash" subj=mauricio:user_r:user_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,bash,user_t,admin_home_t,file,read
audit2allow suggests:

#============= user_t ==============
allow user_t admin_home_t:file read;

Comment 1 Miroslav Grepl 2010-12-02 09:38:39 UTC

*** This bug has been marked as a duplicate of bug 659145 ***


Note You need to log in before you can comment on or make changes to this bug.