Bug 65921 - LVM Support Missing for Installs
LVM Support Missing for Installs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda-images (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-04 08:28 EDT by Jeff Rush
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 08:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Rush 2002-06-04 08:28:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-31tau i686)

Description of problem:
Upgrading a system running 7.2 to 7.3 that uses LVM for all partitions
except root.  During the install process, after selecting =upgrade=,
it mounts the root under /mnt/sysimage but then fails to mount
the other partitions, and the install fails with a pop-up message about not
being able to mount /archive (one of my partitions) and
that it is probably not formatted.

The problem, seen earlier in the install sequence on the F3 screen,
is that the install goes to load a list of modules, all of which
load successfully *except* for xfs, jfs and lvm-mod.  I don't care
about xfs or jfs, but I need lvm-mod.

Can you provide a replacement drivers diskette w/lvm-mod, or just
instruct me where to obtain/place the module in the install disks, I
can proceed from there.  I tried to insert the lvm-mod.o that comes
with the full kernel RPM into a drivers diskette modules.cgz, but it
can't load due to unsatisified kernel symbol references.  Another
idea is to somehow rebuild the vmlinuz image on the install floppy
with LVM support compiled in.

I submitted this bug thru paid-for support, and Philip Morales of Red
Hat closed it and said to open it here where the developers would see
it.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade a Red Hat 7.2 with a single LVM partition


Additional info:

The lvm-mod.o file is only 49KB and there is over 100KB free on
the drivers diskette.
Comment 1 Jeremy Katz 2002-06-29 17:36:51 EDT
LVM is not supported in the installer for Red Hat Linux 7.3.  Just adding the
module is, sadly, not nearly enough to get LVM upgrades working.
Comment 2 Jeff Rush 2002-06-29 20:40:23 EDT
Thanks, katzj.  Before you close this issue could you append just a _few_
lines of what the problem areas are, as I'll need to manually upgrade my sys
then.  Just tips for what I can expect to run into to...

Note You need to log in before you can comment on or make changes to this bug.