Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 659213 - Environment variable USER not set in Solaris
Summary: Environment variable USER not set in Solaris
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: 389
Classification: Retired
Component: Command Line Utilities
Version: 1.2.7
Hardware: Unspecified
OS: Other
low
low
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-02 08:12 UTC by Carsten Grzemba
Modified: 2015-11-19 19:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 19:59:40 UTC


Attachments (Terms of Use)

Description Carsten Grzemba 2010-12-02 08:12:03 UTC
Description of problem:
The scripts [start|stop|restart]-dirsrv evaluate the environment variable USER. This variable is not set in Solaris. There variable LOGNAME must be used.

Version-Release number of selected component (if applicable):
389-Directory/1.2.7.a5 B2010.321.1334


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
if run these scripts as a user other than root, the initconfig_dir is not set.

Expected results:


Additional info:

Comment 2 Martin Kosek 2012-01-04 13:29:36 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/73

Comment 4 Noriko Hosoi 2015-11-19 19:59:40 UTC
Closing this bug since we moved to the ticket system:
https://fedorahosted.org/389/ticket/73


Note You need to log in before you can comment on or make changes to this bug.