This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 65926 - vmware problems with gcc 3.1 and kernel 2.4.18
vmware problems with gcc 3.1 and kernel 2.4.18
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-04 10:06 EDT by Sergey V. Udaltsov
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 10:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergey V. Udaltsov 2002-06-04 10:06:50 EDT
Updated gcc to 3.1 (rpm gcc-3.1-2) and stock RH kernel 2.4.18-0.26. Rebuilt the
kernel with gcc. Kernel is loading and working OK.

But vmware 3.1 kernel modules crash the system (kernel OOPs). Even after running
vmware-config.pl... With gcc 2.96 everything was OK. Is gcc 3 supported as
kernel compiler by RH?
Comment 1 Arjan van de Ven 2002-06-04 10:10:11 EDT
I don't think we officially support gcc 3.x for anything (at least without a
special GCC support contract). For kernels you'd want the latest kernel at
least, and even if the kernel would work, it's unsure if the vmware modules are
gcc 3.x ready.

One thing you should never ever do: mix 2.96 and 3.x gcc's kernel wise. With
that I mean for example compiling the vmlinuz with 3.x and modules with 2.96 or
the other way around. All should be compiled with the EXACT same gcc.
Comment 2 Sergey V. Udaltsov 2002-06-04 10:21:34 EDT
Thanks for explanations. Sure, all modules and kernel are built with the same
version of gcc. So for gcc3/kernel I have to wait for RH 8.0, doesn't I?
Comment 3 Arjan van de Ven 2002-06-04 11:21:15 EDT
We haven't tested the 7.3 kernel with gcc 3; so I expect that the first release
using gcc 3.x would be the first one where we do. No comment about version
numbers for that release.

I'll close this bug as "defered" since it's for some next release

Note You need to log in before you can comment on or make changes to this bug.