Bug 659263 - X server crashes at startup if more than 256 interfaces are defined on the system
X server crashes at startup if more than 256 interfaces are defined on the sy...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.6
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-02 05:47 EST by Olivier Fourdan
Modified: 2015-05-11 07:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script to create the interfaces (431 bytes, text/plain)
2010-12-02 05:47 EST, Olivier Fourdan
no flags Details
Patch backported from git commit 0eb19f94 upstream (447 bytes, patch)
2010-12-02 05:49 EST, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 20675 None None None Never

  None (edit)
Description Olivier Fourdan 2010-12-02 05:47:18 EST
Created attachment 464220 [details]
Script to create the interfaces

Description of problem:

With more than 256 interfaces on a system, the X sever will fail to start and crash (that affects all server variants Xorg, Xnest, etc.)

Version-Release number of selected component (if applicable):

xorg-x11-server-1.1.1-48.76.el5_5

How reproducible:

Always

Steps to Reproduce:
1. Create more then 250 network interfaces with the attached shell script
2. STart a X server such as Xnest
  
Actual results:

/lib64/libc.so.6(__libc_start_main+0xf4)[0x35b621d994]
Xnest[0x41e0a9]
======= Memory map: ========
00400000-00752000 r-xp 00000000 fd:00 100516                             /usr/bin/Xnest
00952000-0098e000 rw-p 00352000 fd:00 100516                             /usr/bin/Xnest
0098e000-009ac000 rw-p 0098e000 00:00 0 
0137f000-013a0000 rw-p 0137f000 00:00 0                                  [heap]
35b5e00000-35b5e1c000 r-xp 00000000 fd:00 262928                         /lib64/ld-2.5.so
35b601b000-35b601c000 r--p 0001b000 fd:00 262928                         /lib64/ld-2.5.so
35b601c000-35b601d000 rw-p 0001c000 fd:00 262928                         /lib64/ld-2.5.so
35b6200000-35b634e000 r-xp 00000000 fd:00 263448                         /lib64/libc-2.5.so
35b634e000-35b654e000 ---p 0014e000 fd:00 263448                         /lib64/libc-2.5.so
35b654e000-35b6552000 r--p 0014e000 fd:00 263448                         /lib64/libc-2.5.so
35b6552000-35b6553000 rw-p 00152000 fd:00 263448                         /lib64/libc-2.5.so
35b6553000-35b6558000 rw-p 35b6553000 00:00 0 
35b6600000-35b6682000 r-xp 00000000 fd:00 271202                         /lib64/libm-2.5.so
35b6682000-35b6881000 ---p 00082000 fd:00 271202                         /lib64/libm-2.5.so
35b6881000-35b6882000 r--p 00081000 fd:00 271202                         /lib64/libm-2.5.so
35b6882000-35b6883000 rw-p 00082000 fd:00 271202                         /lib64/libm-2.5.so
35b6a00000-35b6a02000 r-xp 00000000 fd:00 271200                         /lib64/libdl-2.5.so
35b6a02000-35b6c02000 ---p 00002000 fd:00 271200                         /lib64/libdl-2.5.so
35b6c02000-35b6c03000 r--p 00002000 fd:00 271200                         /lib64/libdl-2.5.so
35b6c03000-35b6c04000 rw-p 00003000 fd:00 271200                         /lib64/libdl-2.5.so
35b7200000-35b7214000 r-xp 00000000 fd:00 101221                         /usr/lib64/libz.so.1.2.3
35b7214000-35b7413000 ---p 00014000 fd:00 101221                         /usr/lib64/libz.so.1.2.3
35b7413000-35b7414000 rw-p 00013000 fd:00 101221                         /usr/lib64/libz.so.1.2.3
35b7600000-35b7705000 r-xp 00000000 fd:00 101214                         /usr/lib64/libX11.so.6.2.0
35b7705000-35b7905000 ---p 00105000 fd:00 101214                         /usr/lib64/libX11.so.6.2.0
35b7905000-35b790c000 rw-p 00105000 fd:00 101214                         /usr/lib64/libX11.so.6.2.0
35b7a00000-35b7a02000 r-xp 00000000 fd:00 101212                         /usr/lib64/libXau.so.6.0.0
35b7a02000-35b7c01000 ---p 00002000 fd:00 101212                         /usr/lib64/libXau.so.6.0.0
35b7c01000-35b7c02000 rw-p 00001000 fd:00 101212                         /usr/lib64/libXau.so.6.0.0
35b7e00000-35b7e05000 r-xp 00000000 fd:00 101213                         /usr/lib64/libXdmcp.so.6.0.0
35b7e05000-35b8004000 ---p 00005000 fd:00 101213                         /usr/lib64/libXdmcp.so.6.0.0
35b8004000-35b8005000 rw-p 00004000 fd:00 101213                         /usr/lib64/libXdmcp.so.6.0.0
35b8200000-35b8210000 r-xp 00000000 fd:00 101237                         /usr/lib64/libXext.so.6.4.0
35b8210000-35b8410000 ---p 00010000 fd:00 101237                         /usr/lib64/libXext.so.6.4.0
35b8410000-35b8411000 rw-p 00010000 fd:00 101237                         /usr/lib64/libXext.so.6.4.0
35b8600000-35b867f000 r-xp 00000000 fd:00 101242                         /usr/lib64/libfreetype.so.6.3.10
35b867f000-35b887f000 ---p 0007f000 fd:00 101242                         /usr/lib64/libfreetype.so.6.3.10
35b887f000-35b8884000 rw-p 0007f000 fd:00 101242                         /usr/lib64/libfreetype.so.6.3.10
35b8a00000-35b8a02000 r-xp 00000000 fd:00 262650                         /lib64/libpam_misc.so.0.81.3
35b8a02000-35b8c02000 ---p 00002000 fd:00 262650                         /lib64/libpam_misc.so.0.81.3
35b8c02000-35b8c03000 rw-p 00002000 fd:00 262650                         /lib64/libpam_misc.so.0.81.3
35b8e00000-35b8e6f000 r-xp 00000000 fd:00 101404                         /usr/lib64/libXfont.so.1.4.1
35b8e6f000-35b906f000 ---p 0006f000 fd:00 101404                         /usr/lib64/libXfont.so.1.4.1
35b906f000-35b907a000 rw-p 0006f000 fd:00 101404                         /usr/lib64/libXfont.so.1.4.1
35b907a000-35b9089000 rw-p 35b907a000 00:00 0 
35ba200000-35ba205000 r-xp 00000000 fd:00 101403                         /usr/lib64/libfontenc.so.1.0.0
35ba205000-35ba405000 ---p 00005000 fd:00 101403                         /usr/lib64/libfontenc.so.1.0.0
35ba405000-35ba407000 rw-p 00005000 fd:00 101403                         /usr/lib64/libfontenc.so.1.0.0
35bae00000-35bae17000 r-xp 00000000 fd:00 271210                         /lib64/libaudit.so.0.0.0
35bae17000-35bb016000 ---p 00017000 fd:00 271210                         /lib64/libaudit.so.0.0.0
35bb016000-35bb018000 rw-p 00016000 fd:00 271210                         /lib64/libaudit.so.0.0.0
35bb200000-35bb20b000 r-xp 00000000 fd:00 271296                         /lib64/libpam.so.0.81.5
35bb20b000-35bb40a000 ---p 0000b000 fd:00 271296                         /lib64/libpam.so.0.81.5
35bb40a000-35bb40b000 rw-p 0000a000 fd:00 271296                         /lib64/libpam.so.0.81.5
35bb600000-35bb63b000 r-xp 00000000 fd:00 271205                         /lib64/libsepol.so.1
35bb63b000-35bb83b000 ---p 0003b000 fd:00 271205                         /lib64/libsepol.so.1
35bb83b000-35bb83c000 rw-p 0003b000 fd:00 271205                         /lib64/libsepol.so.1
35bb83c000-35bb846000 rw-p 35bb83c000 00:00 0 
35bbe00000-35bbe15000 r-xp 00000000 fd:00 271206                         /lib64/libselinux.so.1
35bbe15000-35bc015000 ---p 00015000 fd:00 271206                         /lib64/libselinux.so.1
35bc015000-35bc017000 rw-p 00015000 fd:00 271206                         /lib64/libselinux.so.1
35bc017000-35bc018000 rw-p 35bc017000 00:00 0 
2aed36ae6000-2aed36ae7000 rw-p 2aed36ae6000 00:00 0 
2aed36b11000-2aed36b19000 rw-p 2aed36b11000 00:00 0 
2aed36b19000-2aed36b26000 r-xp 00000000 fd:00 271428                     /lib64/libgcc_s-4.1.2-20080825.so.1
2aed36b26000-2aed36d26000 ---p 0000d000 fd:00 271428                     /lib64/libgcc_s-4.1.2-20080825.so.1
2aed36d26000-2aed36d27000 rw-p 0000d000 fd:00 271428                     /lib64/libgcc_s-4.1.2-20080825.so.1
2aed38000000-2aed38021000 rw-p 2aed38000000 00:00 0 
2aed38021000-2aed3c000000 ---p 2aed38021000 00:00 0 
7fff10ca3000-7fff10cb8000 rw-p 7ffffffea000 00:00 0                      [stack]
ffffffffff600000-ffffffffffe00000 ---p 00000000 00:00 0                  [vdso]
Aborted (core dumped)

(gdb) bt
#0  0x00000035b6230265 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00000035b6231d10 in abort () at abort.c:88
#2  0x00000035b626a99b in __libc_message (do_abort=2, fmt=0x35b6322708 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:170
#3  0x00000035b62748f4 in malloc_printerr (av=0x35b65539e0, oldp=0xbb0b20, nb=32) at malloc.c:6205
#4  _int_realloc (av=0x35b65539e0, oldp=0xbb0b20, nb=32) at malloc.c:5158
#5  0x00000035b62753e2 in __libc_realloc (oldmem=0xbb0b30, bytes=16) at malloc.c:3768
#6  0x00000000006add6b in Xrealloc (ptr=0xf86, amount=<value optimized out>) at utils.c:1471
#7  0x00000035b7e01f13 in XdmcpReallocARRAYofARRAY8 (array=0x9a32d0, length=3974) at RaAoA8.c:45
#8  0x00000000006b68a0 in XdmcpRegisterConnection (type=0, address=0xbae824 "\001\002\006\001", addrlen=4) at xdmcp.c:502
#9  0x00000000006a8f90 in DefineSelf (fd=<value optimized out>) at access.c:1060
#10 0x00000000006aaf23 in CreateWellKnownSockets () at connection.c:432
#11 0x0000000000445ad3 in main (argc=2, argv=0x7fffffffe8e8, envp=0x7fffffffe900) at main.c:318

Expected results:

No crash

Additional info:

It's https://bugs.freedesktop.org/show_bug.cgi?id=20675 fixed by http://cgit.freedesktop.org/xorg/xserver/commit/?id=0eb19f9437b7d8c19592e49eedb028771d300d80

Patch attached.
Comment 1 Olivier Fourdan 2010-12-02 05:49:11 EST
Created attachment 464221 [details]
Patch backported from git commit 0eb19f94 upstream
Comment 2 RHEL Product and Program Management 2011-05-31 11:35:25 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-10-30 01:59:38 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2014-03-07 07:17:50 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 6 RHEL Product and Program Management 2014-06-02 09:07:26 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.