Bug 6593 - mv erroneously does recursive moves
mv erroneously does recursive moves
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-01 03:14 EST by tony
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 15:21:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tony 1999-11-01 03:14:24 EST
ls -l
[several files and directories listed]
mkdir dir
mv * dir
[long pause, disk thrashing, not good]
^C
ls -F
dir/
ls -l dir/
[moved files + dir/]
ls -l dir/dir/
[moved files + another dir/ !!!]

Bad news.  mv should complain about an "invalid arguement"
when trying to mv dir/ into dir/ and should not do it
recursively.
Comment 1 Bernhard Rosenkraenzer 2000-02-17 15:21:59 EST
Works for me with 4.0-19

Note You need to log in before you can comment on or make changes to this bug.