Bug 659378 - [abrt] shutter-0.86.4-1.fc14: _gnome_vfs_monitor_do_cancel: Process /usr/bin/perl was killed by signal 11 (SIGSEGV)
Summary: [abrt] shutter-0.86.4-1.fc14: _gnome_vfs_monitor_do_cancel: Process /usr/bin/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shutter
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Liang Suilong
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:46a5b7f059ac268680eb75a3ead...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-02 16:57 UTC by Alan Ernhart
Modified: 2012-08-30 00:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-16 22:39:12 UTC


Attachments (Terms of Use)
File: backtrace (32.41 KB, text/plain)
2010-12-02 16:57 UTC, Alan Ernhart
no flags Details

Description Alan Ernhart 2010-12-02 16:57:44 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/perl /usr/bin/shutter
comment: I hope this helps. Thanks for all the greatness here! Contact me if you need anything.
component: shutter
crash_function: _gnome_vfs_monitor_do_cancel
executable: /usr/bin/perl
kernel: 2.6.36.1-10.fc15.x86_64
package: shutter-0.86.4-1.fc14
rating: 4
reason: Process /usr/bin/perl was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1291307042
uid: 500

How to reproduce
-----
1. In Shutter I had several tabs open with screenshots. With one of them, I had been looking for how to re-scale it, going into the Editor and back out without saving anything. I then looked up elsewhere that there's a Plugin that provides the rescalng. So I opened the plugins dialog that allows me to apply effects to my image. Just browsing them at this point, I tried the 3d-Rotate one (or similarly named) and chose not to save the change. Then I tried a plugin one or two places below that in the last and that's when Shutter crashed. 
2. I've not tried to reproduce this yet.
3.

Comment 1 Alan Ernhart 2010-12-02 16:57:48 UTC
Created attachment 464298 [details]
File: backtrace

Comment 2 Alan Ernhart 2010-12-02 17:14:32 UTC
I just reproduced it. Steps:

I have the Preferences set to Automatically save file to screenshot_%NNN and to automatically copy to clipboard.

- Take a screenshot via Selection (and in case it matters, I had 3 tabs open already).
- Screenshot -> Run a Plugin...
- Select the Shutter Branding plugin. Run it.
- The image is modified and seems correct, but I didn't intend to keep it.

At this point, the image with the Shutter Branding applied has been written to disk, but the un-branded, or initial image is on the clipboard.

- Decide that you don't like the change, so select Edit -> Undo. Crash.

I hope these steps are sufficient. If you need more specifics, e.g. my full set of Preferences or more detailed steps, please contact me.

While this is a crash, it's quick to recover from with very minimal data loss and I expect that I can both avoid it and get what I'd like from Shutter. Triage accordingly.

Thanks.

Comment 3 Fedora Update System 2012-08-10 15:23:48 UTC
shutter-0.89-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/shutter-0.89-1.fc16

Comment 4 Fedora Update System 2012-08-10 22:36:31 UTC
Package shutter-0.89-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shutter-0.89-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11735/shutter-0.89-1.fc16
then log in and leave karma (feedback).

Comment 5 Fedora End Of Life 2012-08-16 22:39:14 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Fedora Update System 2012-08-20 14:29:01 UTC
perl-X11-Protocol-Other-18-1.fc16, shutter-0.89.1-2.fc16, perl-Net-Dropbox-API-1.8-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-12026/perl-X11-Protocol-Other-18-1.fc16,perl-Net-Dropbox-API-1.8-3.fc16,shutter-0.89.1-2.fc16

Comment 7 Fedora Update System 2012-08-30 00:51:38 UTC
perl-X11-Protocol-Other-18-1.fc16, shutter-0.89.1-2.fc16, perl-Net-Dropbox-API-1.8-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.