Bug 659391 - cups won't stop on reboot or halt
Summary: cups won't stop on reboot or halt
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 14
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 659692
TreeView+ depends on / blocked
 
Reported: 2010-12-02 17:37 UTC by Gus Wirth
Modified: 2011-04-17 21:25 UTC (History)
2 users (show)

(edit)
Clone Of:
: 659692 (view as bug list)
(edit)
Last Closed: 2011-01-18 21:33:13 UTC


Attachments (Terms of Use)
patch to fix cups shutdown problem (319 bytes, patch)
2010-12-02 17:37 UTC, Gus Wirth
no flags Details | Diff

Description Gus Wirth 2010-12-02 17:37:30 UTC
Created attachment 464306 [details]
patch to fix cups shutdown problem

Description of problem:

When rebooting or halting a system with the CUPS service running, the CUPS
service won't stop normally. Instead, it has to be killed in the final stage of reboot or shutdown. This is almost identical to bug 652786 except it's CUPS and not NFS.

Version-Release number of selected component (if applicable):

cups-1.4.4-11.fc14.i686

How reproducible:

Operate system normally with CUPS service running. 

Steps to Reproduce:
1. Have CUPS start either on runlevel or manual start
2. Reboot or halt system


Actual results:

CUPS fails to stop. The cupsd daemon has to be killed in the final moment before shutdown or reboot.

Expected results:

CUPS service stops normally without having to be killed outside its init script.

Additional info:

If CUPS is stopped manually before reboot/halt like so:

# service cups stop

it will stop cleanly and show appropriate messages for various components.
However, when the system is rebooting or halting no CUPS messages are seen,
seeming to indicate that it never shuts down.

The bug exists because the subsystem lock file name does not match
the init script name. The /etc/rc.d/rc script checks to see if a subsytem is
running by using the name of the init script for the subsystem file. In the
case of the CUPS subsystem, the CUPS init script creates a subsysetm file
/var/lock/subsys/cupsd. It should be cups (no d on the end).

A simple tweak to the init script fixes the problem. Patch attached.

Comment 1 Jiri Popelka 2010-12-03 13:39:51 UTC
Thank you.

Commited with a little tweak.
http://pkgs.fedoraproject.org/gitweb/?p=cups.git;a=commitdiff;h=f0480cb93d795bd368ceed5e251bde0c50b4bca9

Comment 2 Fedora Update System 2011-01-07 12:30:59 UTC
cups-1.4.6-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cups-1.4.6-1.fc14

Comment 3 Fedora Update System 2011-01-07 12:31:58 UTC
cups-1.4.6-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/cups-1.4.6-1.fc13

Comment 4 Fedora Update System 2011-01-07 19:57:46 UTC
cups-1.4.6-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/cups-1.4.6-1.fc13

Comment 5 Fedora Update System 2011-01-18 21:32:52 UTC
cups-1.4.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-04-17 21:25:19 UTC
cups-1.4.6-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.