Bug 659501 - compat-libtermcap-2.0.8-49.el6.x86_64.rpm does not install any files
Summary: compat-libtermcap-2.0.8-49.el6.x86_64.rpm does not install any files
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: compat-libtermcap
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-02 22:19 UTC by Dan Locks
Modified: 2010-12-03 17:42 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-12-03 17:42:48 UTC


Attachments (Terms of Use)

Description Dan Locks 2010-12-02 22:19:07 UTC
Description of problem:
compat-libtermcap for x86_64 does not install any files or create any links.  I have not checked i686.

Version-Release number of selected component (if applicable):
2.0.8-49.el6.x86_64

How reproducible:
Just install compat-libtermcap

Steps to Reproduce:
1. yum install libtermcap
2. find /usr/lib64
3.
  
Actual results:

[root@foo tmp]# find /usr/lib64 -name "libterm*"
/usr/lib64/libtermcap.so

[root@foo tmp]# yum install compat-libtermcap
Loaded plugins: rhnplugin
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package compat-libtermcap.x86_64 0:2.0.8-49.el6 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================
 Package                               Arch                       Version      
                      Repository                                Size
=====================================================================================================================================================
Installing:
 compat-libtermcap                     x86_64                     2.0.8-49.el6 
                      rhel-x86_64-server-6                      16 k

Transaction Summary
=====================================================================================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 16 k
Installed size: 0  
Is this ok [y/N]: y
Downloading Packages:
compat-libtermcap-2.0.8-49.el6.x86_64.rpm                                      
                                              |  16 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : compat-libtermcap-2.0.8-49.el6.x86_64                       
                                                                 1/1 

Installed:
  compat-libtermcap.x86_64 0:2.0.8-49.el6                                       
Complete!

[root@foo tmp]# find /usr/lib64 -name "libterm*"
/usr/lib64/libtermcap.so
-------------------
[root@foo tmp]# rpm -V compat-libtermcap-2.0.8-49.el6.x86_64.rpm 
package compat-libtermcap-2.0.8-49.el6.x86_64.rpm is not installed
[root@foo tmp]# rpm -i compat-libtermcap-2.0.8-49.el6.x86_64.rpm 
        package compat-libtermcap-2.0.8-49.el6.x86_64 is already installed

That's not right!

Expected results:
/usr/lib64/libtermcap.so.2 should either be a file or a symlink.

Additional info:
Same info posted to bug 607251.  Sorry if this creates bugspam.

Comment 1 Dan Locks 2010-12-02 22:22:27 UTC
Side note: I tried to add the old bug id to the "see also" field, but could not.  The error says the reporter should be able to change this field.

Comment 3 Jeff Bastian 2010-12-02 23:41:34 UTC
Note that with the 'rpm -V' command, you need to give it the package name, not the filename of the package:
    [root@foo ~]# rpm -V compat-libtermcap
    [root@foo ~]#


Next, you don't need to re-install the package with 'rpm -i' because you just installed it with 'yum install' which is what the error message was telling you:
    package compat-libtermcap-2.0.8-49.el6.x86_64 is already installed


Finally, the symlinks are in /lib64, not /usr/lib64:
    [root@foo ~]# rpm -ql compat-libtermcap
    /etc/termcap
    /lib64/libtermcap.so.2
    /lib64/libtermcap.so.2.0.8


Please verify that you have the symlinks in /lib64.

Comment 4 Dan Locks 2010-12-03 05:44:45 UTC
I guess trying to be more explicit didn't actually add any clarity. Yum installed compat-libtermcap successfully.  It was when I didn't find any symlinks that I tried rpm -V (incorrectly).  Here's the result showing a correct invocation of rpm -V, with the same out put as you showed (none).  But there aren't any symlinks. /etc/termcap gets installed, though.


[root@foo ~]# rpm -V compat-libtermcap
[root@foo ~]# find /usr/lib64 -name "libtermcap.so.2*"
[root@foo ~]#
[root@foo ~]# find /etc/termcap
/etc/termcap

I checked my rhel6 32bit vm, and have the same problem, so the problem is not confined to x86_64

yumdownloader couldn't find any .src.rpms for compat-libtermcap.  Is that normal for RHN repositories?

Thanks for the quick response!

Comment 5 Miroslav Lichvar 2010-12-03 07:56:36 UTC
The files should be in /lib64, not in /usr/lib64.

Comment 6 Dan Locks 2010-12-03 17:17:52 UTC
oh. yeah.  The links are in /lib64. 

So that means the problem is with the rpm I'm editing not specifying libtermcap.so.2 correctly in BuildRequires.  Please close this with "notabug".


Note You need to log in before you can comment on or make changes to this bug.