Bug 659674 - can't rebuild test failed
can't rebuild test failed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: guile (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Miroslav Lichvar
BaseOS QE - Apps
: Patch
Depends On:
Blocks: GSS_6_2_PROPOSED 697582
  Show dependency treegraph
 
Reported: 2010-12-03 07:39 EST by Levente Farkas
Modified: 2011-06-15 11:38 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to a problem in the build test suite, the guile package failed to build. The problem has been resolved in this update so that the guile package now builds properly.
Story Points: ---
Clone Of:
: 712814 (view as bug list)
Environment:
Last Closed: 2011-06-08 04:26:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from guile-1.8.7-6.fc14 (2.07 KB, patch)
2010-12-15 14:59 EST, J.H.M. Dassen (Ray)
no flags Details | Diff

  None (edit)
Description Levente Farkas 2010-12-03 07:39:11 EST
guile-1.8.7-4.el6.src.rpm can't be rebuild in mock since test always failed as:
----------------------------------
libtool: link: gcc -I../../test-suite/standalone -I../.. -I../.. -pthread -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fas
ynchronous-unwind-tables -Wall -Wmissing-prototypes -pthread -o .libs/test-scm-with-guile test_scm_with_guile-test-scm-with-guile.o  ../../libguile/.libs/libguile.so -lgmp -lcrypt -lm -lltdl -pthread
make[4]: Leaving directory `/builddir/build/BUILD/guile-1.8.7/test-suite/standalone'
make  check-TESTS
make[4]: Entering directory `/builddir/build/BUILD/guile-1.8.7/test-suite/standalone'
PASS: test-system-cmds
PASS: test-require-extension
PASS: test-bad-identifiers
PASS: test-num2integral
PASS: test-round
PASS: test-gh
ERROR: In procedure dynamic-link:
ERROR: file: "libtest-asmobs", message: "file not found"
FAIL: test-asmobs
PASS: test-list
PASS: test-unwind
PASS: test-conversion
PASS: test-fast-slot-ref
PASS: test-use-srfi
PASS: test-scm-c-read
PASS: test-scm-take-locale-symbol
PASS: test-with-guile-module
PASS: test-scm-with-guile
==================================
1 of 16 tests failed
Please report to bug-guile@gnu.org
==================================
make[4]: Leaving directory `/builddir/build/BUILD/guile-1.8.7/test-suite/standalone'
make[4]: *** [check-TESTS] Error 1
make[3]: *** [check-am] Error 2
make[2]: *** [check] Error 2
make[3]: Leaving directory `/builddir/build/BUILD/guile-1.8.7/test-suite/standalone'
make[2]: Leaving directory `/builddir/build/BUILD/guile-1.8.7/test-suite/standalone'
make[1]: Leaving directory `/builddir/build/BUILD/guile-1.8.7/test-suite'
make[1]: *** [check-recursive] Error 1
make: *** [check-recursive] Error 1
----------------------------------
Comment 2 Tuomo Soini 2010-12-03 07:44:31 EST
Patch for this issue is in fedora 1.8.7-5 package.
Comment 3 J.H.M. Dassen (Ray) 2010-12-15 14:59:22 EST
Created attachment 468951 [details]
Patch from guile-1.8.7-6.fc14

This patch from guile-1.8.7-6.fc14 fixes the problem for me on RHEL6 with the RHEL6 guile sources.
Comment 4 Suzanne Yeghiayan 2011-01-05 14:48:49 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated 
in the current release, Red Hat is unfortunately unable to 
address this request at this time.  This request has been 
proposed for the next release of Red Hat Enterprise Linux.
If you would like it considered as an exception in the 
current release, please ask your support representative.
Comment 5 Zenon Panoussis 2011-03-13 05:35:15 EDT
The patch of comment #3 is upsteam at http://git.savannah.gnu.org/gitweb/?p=guile.git;a=commitdiff;h=5b98517a652ea51cbb0fd03e87a50c0b3add9707 and was committed in December 2009. This bug has cascading consequences; several other packages depend on guile and won't build either until this is fixed. 

Confirming that the patch works. It needs this in addition:

--- guile.spec.orig	2009-11-30 16:52:14.000000000 +0100
+++ guile.spec	2011-03-13 10:32:27.479571876 +0100
@@ -12,6 +12,7 @@
 Patch3: guile-1.8.7-ia64jmp.patch
 Patch4: guile-1.8.6-deplibs.patch
 Patch5: guile-1.8.7-linemarkers.patch
+Patch6: guile-1.8.7-libtest-asmobs.patch
 License: GPLv2+ and LGPLv2+
 Group: Development/Languages
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -55,6 +56,7 @@
 %patch3 -p1 -b .ia64jmp
 %patch4 -p1 -b .deplibs
 %patch5 -p1 -b .linemarkers
+%patch6 -p1
 
 %build
Comment 13 errata-xmlrpc 2011-06-08 04:26:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0855.html
Comment 14 Petr Kovar 2011-06-15 11:38:58 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to a problem in the build test suite, the guile package failed to build. The problem has been resolved in this update so that the guile package now builds properly.

Note You need to log in before you can comment on or make changes to this bug.