This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 659720 - manpage not in sync with options logrotate actually recognizes
manpage not in sync with options logrotate actually recognizes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logrotate (Show other bugs)
6.1
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: ManPageChange
Depends On: 642936 644308
Blocks: MPO-6.3-REMOVE
  Show dependency treegraph
 
Reported: 2010-12-03 10:02 EST by Ivana Varekova
Modified: 2012-06-20 08:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: logrotate-3.7.8-15.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 644308
Environment:
Last Closed: 2012-06-20 08:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivana Varekova 2010-12-03 10:02:11 EST
+++ This bug was initially created as a clone of Bug #644308 +++

+++ This bug was initially created as a clone of Bug #642936 +++

Version-Release number of selected component (if applicable):
logrotate-3.7.4-9.el5_5.1

Steps to Reproduce:
# ./compare-options.sh /usr/sbin/logrotate 
Program path:
	/usr/sbin/logrotate
Man pages found:
	/usr/share/man/man8/logrotate.8.gz
The binary analysis was NOT done
Doing man page vs. usage message comparison

The program reported 13 option(s)
The man page reported 12 option(s)
9 COMMON option(s):
	--force
	--mail
	--state
	--usage
	-d
	-f
	-m
	-s
	-v
4 option(s) reported by the program ONLY:
	--debug
	--help
	--verbose
	-?
3 option(s) reported by the man page ONLY:
	-HUP
	-dv
	-force

-HUP is false positive (it is used in text like an example of killall)
-dv is false positive (it is combination of -d and -v)

Actual results: 
no all parameters of program are in man page and 1 in man page is wrong (typo)

Expected results:
all parameters in program and man page are same

--- Additional comment from jkaluza@redhat.com on 2010-10-19 07:46:28 EDT ---

Created attachment 454331 [details]
proposed patch

This patch corrects the man page.
Comment 8 errata-xmlrpc 2012-06-20 08:39:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0786.html

Note You need to log in before you can comment on or make changes to this bug.