Bug 659723 - torque-2.4.10 from RHEL 6 not backporable to RHEL 5
Summary: torque-2.4.10 from RHEL 6 not backporable to RHEL 5
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: torque
Version: el6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-03 15:05 UTC by Nico Kadel-Garcia
Modified: 2010-12-08 11:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-08 11:56:39 UTC
Type: ---


Attachments (Terms of Use)

Description Nico Kadel-Garcia 2010-12-03 15:05:14 UTC
Description of problem:
  torque-2.4.10 SRPM backport fails compilation on RHEL 5 due to 'BuildArch: noarch' settings.

Version-Release number of selected component (if applicable):
  torque-2.4.10-1.el6.src.rpm

How reproducible:
   Extract contents of torque-2.4.10 SRPM from Fedora Core 14, try to build on RHEL 5.

Steps to Reproduce:
1. Extract contents of SRPM
2. Copy files to [rpmdir]/SOURCES
3. rpmbuiild -ba [rpmdir]/SOURCES/torque.spec
  
Actual results:
  Compilation on RHEL 5 fails due to unallocated debug components.

Expected results:
  Successful compilation.

Additional info:
  Fixing this will allow torque-2.4.10, or 2.4.11, to be backported gracefully to RHEL 5.

  The solution for this is already included in the "git" SRPM. The .spec file needs to filter for compilation on Fedora < version 10, or RHEL < version 6, and disable the "BuildArch: noarch" setting if present.

Here is the patch:

diff -c -r1.1 torque-rh6.spec
*** torque-rh6.spec     2010/12/03 15:01:47     1.1
--- torque-rh6.spec     2010/12/03 15:02:08
***************
*** 124,130 ****
--- 124,132 ----
  Group:          Documentation
  Summary:        Documentation files for TORQUE
  Requires:       %{name} = %{version}-%{release}
+ %if 0%{?fedora} >= 10 || 0%{?rhel} >= 6
  BuildArch:      noarch
+ %endif

  %description docs
  TORQUE (Tera-scale Open-source Resource and QUEue manager) is a resource

Comment 1 Steve Traylen 2010-12-03 15:21:14 UTC
Okay, I'll add this sometime.

Comment 2 Steve Traylen 2010-12-08 11:56:39 UTC
Hi Nico,

What do you mean by the "git" SRPM?

Have added the fix to both EPEL6 build and F15 build.

http://koji.fedoraproject.org/koji/buildinfo?buildID=208305
and
http://koji.fedoraproject.org/koji/buildinfo?buildID=208307

I've not checked if the F15 builds on EPEL5 but I expect so, certainly
I am happy to fix it if there are still problems. Submit a new bug.

You may have an opinion as to if moving the current F15 build to EPEL6 makes
sense while we are still epel6-beta phase? Otherwise we stuck with
2.4 potentially for a long time.

Steve.


Note You need to log in before you can comment on or make changes to this bug.