Bug 659730 - Manual page corrections for find
Manual page corrections for find
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: findutils (Show other bugs)
6.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Kamil Dudka
Branislav Náter
: ManPageChange
Depends On: 657563
Blocks: 1287574
  Show dependency treegraph
 
Reported: 2010-12-03 10:15 EST by Ivana Varekova
Modified: 2016-01-20 04:46 EST (History)
4 users (show)

See Also:
Fixed In Version: findutils-4.4.2-8.el6
Doc Type: Bug Fix
Doc Text:
Needless to document IMO.
Story Points: ---
Clone Of: 657563
Environment:
Last Closed: 2016-01-14 12:24:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivana Varekova 2010-12-03 10:15:14 EST
+++ This bug was initially created as a clone of Bug #657563 +++

Manual page for find needs review and at least one minor correction. Following example from the manual does not work out-of-the-box:
<current>
       find / \
       \( -perm -4000 -fprintf /root/suid.txt %#m %u %p\n \) , \
       \( -size +100M -fprintf /root/big.txt %-10s %p\n \)
</current>

until you add apostrophe around print arguments as it is in RHEL 5 man pages:
<proposed>
       find / \
       \( -perm -4000 -fprintf /root/suid.txt '%#m %u %p\n' \) , \
       \( -size +100M -fprintf /root/big.txt '%-10s %p\n' \)
</proposed>

We can expect other similar typos around, so it should be checked. 

Version-Release number of selected component (if applicable):
findutils-4.4.2-6.el6

--- Additional comment from kdudka@redhat.com on 2010-11-26 13:11:44 EST ---

Good catch!  Fixed upstream in c440d6c:

http://git.savannah.gnu.org/gitweb/?p=findutils.git;a=commitdiff;h=c440d6c
Comment 2 Suzanne Yeghiayan 2012-02-15 12:16:17 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time, but it has been proposed
for the next release.
Comment 3 RHEL Product and Program Management 2012-09-07 01:01:14 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 9 errata-xmlrpc 2016-01-14 12:24:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0038.html

Note You need to log in before you can comment on or make changes to this bug.