Bug 659735 - Pool Refresh Pulse Bar Does Not Handle Errors
Summary: Pool Refresh Pulse Bar Does Not Handle Errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-03 15:19 UTC by Devan Goodwin
Modified: 2013-01-10 10:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:37:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unable to verify server's identity dialog (11.74 KB, image/png)
2011-01-07 19:55 UTC, John Sefler
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description Devan Goodwin 2010-12-03 15:19:18 UTC
Description of problem:

In an exception is thrown while the pulse bar is showing as we query pools from the server, the bar never goes away, stack trace goes to console, GUI sees no indication anything is wrong.

Version-Release number of selected component (if applicable):

git master today.

How reproducible:

100%

Steps to Reproduce:
1. Using a Candlepin dev setup, register your RHSM client.
2. Redeploy Candlepin and repopulate the DB. (gendb=1)
3. Start your RHSM client again, go to All Subscriptions, and hit Search.
  
Actual results:

Progress bar spins forever. You should see a stack trace printed to console about invalid username/password. (this is because the consumer's identity was destroyed upstream, so it's identity cert is no longer valid and thus it cannot be used to authenticate)

Expected results:

Progress bar should handle exceptions and report consistently with the rest of the GUI.

Additional info:

Comment 2 Bryan Kearney 2010-12-03 22:08:21 UTC
I see the error handling only when accessability is on. Not when it is off.

Comment 4 John Sefler 2011-01-07 19:54:03 UTC
moving to VERIFIED.

[root@jsefler-onprem01 ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.93.9-1.git.17.9bab7c0.el6.x86_64

The busy dialog opens for a second and then closes and is replaced by error dialog "Unable to verify server's identity: certificate verify failed"

See following attached screenshot

Comment 5 John Sefler 2011-01-07 19:55:49 UTC
Created attachment 472290 [details]
Unable to verify server's identity dialog

Error dialog opens without breaking the busy dialog.

Comment 6 errata-xmlrpc 2011-05-19 13:37:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.