Bug 659776 - Plugins writers need pkg-config support
Summary: Plugins writers need pkg-config support
Status: CLOSED DUPLICATE of bug 252249
Alias: None
Product: 389
Classification: Retired
Component: Server - Plugins
Version: 1.2.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 639035 389_1.2.8
TreeView+ depends on / blocked
 
Reported: 2010-12-03 16:30 UTC by Simo Sorce
Modified: 2015-01-04 23:45 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-04 17:20:36 UTC


Attachments (Terms of Use)

Description Simo Sorce 2010-12-03 16:30:38 UTC
With the recent switch from using mozldap to openldap libraries plugin writers have no way to know which library to use.
Dirsrv should provide pkg-config support so that plugins can get the right set of libraries to use from pkg-config --libs

Comment 1 Rich Megginson 2010-12-03 16:50:57 UTC
I don't think this affects DSIPA2.0 in RHEL, as long as you can specify in the .spec file for ipa to use mozldap or openldap.  But it does affect development on Fedora.

To really fix this, we need a real 389-ds-base-devel package with pkg-config support and additionally a 389-ds-base-config script that provides the path to slapi-plugin.h (note that openldap also provides slapi-plugin.h in /usr/include), other build flags and libs used to build 389-ds-base.

Comment 2 Rich Megginson 2011-01-04 17:20:36 UTC

*** This bug has been marked as a duplicate of bug 252249 ***


Note You need to log in before you can comment on or make changes to this bug.