Bug 659931 - screen blank on boot HP Pavilion dm4 1160us with Intel HD card
screen blank on boot HP Pavilion dm4 1160us with Intel HD card
Status: CLOSED DUPLICATE of bug 659935
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-04 03:48 EST by dlfg68
Modified: 2010-12-05 18:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 18:07:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport, various Xorg.0.log boot attempts using different kernel settings (762.05 KB, application/gzip)
2010-12-04 03:48 EST, dlfg68
no flags Details

  None (edit)
Description dlfg68 2010-12-04 03:48:06 EST
Created attachment 464715 [details]
sosreport, various Xorg.0.log boot attempts using different kernel settings

Description of problem: 


Version-Release number of selected component (if applicable): Fedora 14 64-bit with latest updates as of 12/03/2010 running on an HP Pavilion dm4 1160us laptop which has an Intel HD card.

How reproducible: Very


Steps to Reproduce:
1. install fedora 14 to local disk from Fedora 14 Live CD and chose to have an encrypted root hard drive
2. upon reboot from install will get a blank screen and can not see disk password prompt
3. blindly typing the password will allow boot to continue but graphical X11 screen will not display
  
Actual results: black screen


Expected results: X11 server using intel driver


Additional info: I'v attached the file linlap01_bugreport.tar.gz which contains an sosreport, various Xorg.0.log boot attempts using different kernel settings.

Description of files in linlap01_bugreport.tar.gz
Fedora 14 files
	sosreport-linlap01-20101204000215-2e50.tar.xz
	Xorg.0.log_boot_default_acpi=off Forced to type encrypted disk password without seeing any display Successfully starts X11 with intel driver.  Brightness controls do not work
	Xorg.0.log_boot_default_drm.debug=0x04 Forced to type encrypted disk password without seeing any display but fails to start X11
	Xorg.0.log_boot_default_noextra-settings Forced to type encrypted disk password without seeing any display but fails to start X11
	Xorg.0.log_fedora14_livecd - boots fine with no problems into X11 using intel driver
	Xorg.0.log_i915.modeset=1  screen is always black.  Forced to type encrypted disk password without seeing any display but fails to start X11
	Xorg.0.log_single_exit_w_nomodeset=1  ( kernel nomodeset ) system will display prompt - Password for filesystem but fails to start X11
	Xorg.0.log_videoLVDS=1e  ( kernel setting video=LVDS-1:e )

In order to debug this I tried another Linux distribution.  I can boot Ubuntu 10.10 with default settings with acpi on and it will successfully load X11 with intel driver
Forced to type encrypted disk password without seeing any display Successfully starts X11 with intel driver. Brightness controls work.
linlap01_ubuntu_10.10.txt  - contains package info for conifguration that works on ubuntu.
messages_ubuntu_10.10 - /var/log/messages from ubuntu 10.10 boot
Xorg.0.log_ubuntu_10.10 - xorg log file which gives working X11 in ubuntu 10.10
Comment 1 dlfg68 2010-12-05 18:07:30 EST

*** This bug has been marked as a duplicate of bug 659935 ***

Note You need to log in before you can comment on or make changes to this bug.