Bug 659949 - SELinux is preventing /usr/bin/mpd "read" access on /usr/share/alsa/alsa.conf.
Summary: SELinux is preventing /usr/bin/mpd "read" access on /usr/share/alsa/alsa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:2ba90aabfb3...
: 659948 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-04 11:55 UTC by matthias.guentert
Modified: 2010-12-13 20:12 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.9.7-16.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-13 20:12:53 UTC
Type: ---


Attachments (Terms of Use)

Description matthias.guentert 2010-12-04 11:55:34 UTC
Summary:

SELinux is preventing /usr/bin/mpd "read" access on /usr/share/alsa/alsa.conf.

Detailed Description:

[mpd has a permissive type (mpd_t). This access was not denied.]

SELinux denied access requested by mpd. It is not expected that this access is
required by mpd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:mpd_t:s0
Target Context                system_u:object_r:alsa_etc_rw_t:s0
Target Objects                /usr/share/alsa/alsa.conf [ file ]
Source                        mpd
Source Path                   /usr/bin/mpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           mpd-0.15.12-1.fc14
Target RPM Packages           alsa-lib-1.0.23-2.fc14
Policy RPM                    selinux-policy-3.9.7-12.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.6-48.fc14.x86_64
                              #1 SMP Fri Oct 22 15:36:08 UTC 2010 x86_64 x86_64
Alert Count                   6
First Seen                    Wed 01 Dec 2010 10:19:50 PM CET
Last Seen                     Sat 04 Dec 2010 12:49:55 PM CET
Local ID                      8f260679-c986-4486-87f2-c94a491be5a2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291463395.788:103): avc:  denied  { read } for  pid=5678 comm="mpd" name="alsa.conf" dev=md2 ino=33038062 scontext=unconfined_u:system_r:mpd_t:s0 tcontext=system_u:object_r:alsa_etc_rw_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1291463395.788:103): avc:  denied  { open } for  pid=5678 comm="mpd" name="alsa.conf" dev=md2 ino=33038062 scontext=unconfined_u:system_r:mpd_t:s0 tcontext=system_u:object_r:alsa_etc_rw_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1291463395.788:103): arch=c000003e syscall=2 success=yes exit=9 a0=23adcf0 a1=0 a2=1b6 a3=0 items=0 ppid=5677 pid=5678 auid=500 uid=491 gid=487 euid=491 suid=491 fsuid=491 egid=487 sgid=487 fsgid=487 tty=pts0 ses=11 comm="mpd" exe="/usr/bin/mpd" subj=unconfined_u:system_r:mpd_t:s0 key=(null)



Hash String generated from  catchall,mpd,mpd_t,alsa_etc_rw_t,file,read
audit2allow suggests:

#============= mpd_t ==============
allow mpd_t alsa_etc_rw_t:file { read open };

Comment 1 Miroslav Grepl 2010-12-06 11:41:11 UTC
*** Bug 659948 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-12-06 12:25:55 UTC
Fixed in selinux-policy-3.9.7-15.fc14

Comment 3 Fedora Update System 2010-12-10 13:54:43 UTC
selinux-policy-3.9.7-16.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-16.fc14

Comment 4 Fedora Update System 2010-12-10 20:29:08 UTC
selinux-policy-3.9.7-16.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-16.fc14

Comment 5 Fedora Update System 2010-12-13 20:11:51 UTC
selinux-policy-3.9.7-16.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.